PlotSquared Walls Not Generating Properly

Discussion in 'Spigot Plugin Help' started by TechBug2012, May 14, 2016.

  1. Hi,
    I have a problem with PlotSquared, specifically on my Creative server. I generate my world with these settings:
    Code (Text):

      plot:
          height: 64
          size: 96
          filling:
          - '3:0'
          floor:
          - '2:0'
          bedrock: true
          biome: FOREST
          create_signs: true
          auto_merge: false
        wall:
          block: '44:6'
          block_claimed: '44:6'
          filling: '2:0'
          height: 64
        road:
          width: 7
          height: 64
          block: '155:0'
        event:
          spawn:
            breeding: false
            egg: false
            custom: true
        economy:
          use: false
          prices:
            claim: 100
            sell: 100
            merge: 100
     
    But when I go to the world, the walls of the plot do not generate properly. They generate with the default stone slab with a few random nether slabs (what I actually want as the walls) scattered around.
    Here's a screenshot of what it is: http://imgur.com/TXp0sk5
    Here's a screenshot of what it should look like (
    minus the roads): http://imgur.com/Pgpeodu
    Here's a list of my plugins:
    upload_2016-5-13_20-9-58.png
    The world generates fine on every other server I've tried except for this one. It must be a plugin, but what plugin could possibly be causing the plot walls to not generate properly? I've tried restarting, checking the console, and re-installing PlotSquared. It always fails to properly generate.

    Thanks for your help!

    EDIT: Not running latest version of Spigot. Updating fixed the problem. Stupid mistake, sorry :/
     
    #1 TechBug2012, May 14, 2016
    Last edited: May 14, 2016
  2. I've tried to use PlotSquared in the past, but every plot plugin is completely broken, I had the same problems, so i just had to not do it sadly. If ANYONE has an idea on how to fix this and/or is there another plot plugin (Apart from abandoned plotme) that works ok?
     
  3. Actually, I noticed that the other servers I tried it on were 1.8.8 and the server that wasn't working was just Spigot 1.8. After updating the one that wasn't working to 1.8.8, the walls started generating properly. The devs of PlotSquared said it was tested with 1.7. 1.8, and 1.9, so I guess it's just a bug on their 1.8 version and worth reporting.
     
    • Agree Agree x 1