Solved Pls help me, error with tmp/Sqlite/

Discussion in 'Spigot Plugin Help' started by KByakko, Jun 18, 2018.

Thread Status:
Not open for further replies.
  1. I need help, I'm sorry, I'm new to preparing plugins for a server.

    during a reboot it happened that an error occurred with the folder / temp /

    I think it is a problem with a database to which, through the "Server.pro" console, I can not access.

    What I can do?

    Code (Text):

    [04:59:48] [Server thread/INFO]: [WorldGuard] Enabling WorldGuard v6.2.1;84bc322
    [04:59:48] [Server thread/WARN]: /tmp/sqlite-3.21.0.1-487ced69-535e-4d11-82b4-fbb9df7a16b6-libsqlitejdbc.so.lck (Permission denied)
    [04:59:48] [Server thread/ERROR]: Error occurred while enabling WorldGuard v6.2.1;84bc322 (Is it up to date?)
    java.lang.UnsatisfiedLinkError: org.sqlite.core.NativeDB._open_utf8([BI)V
        at org.sqlite.core.NativeDB._open_utf8(Native Method) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
        at org.sqlite.core.NativeDB._open(NativeDB.java:71) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
        at org.sqlite.core.DB.open(DB.java:174) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
        at org.sqlite.core.CoreConnection.open(CoreConnection.java:220) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
        at org.sqlite.core.CoreConnection.<init>(CoreConnection.java:76) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
        at org.sqlite.jdbc3.JDBC3Connection.<init>(JDBC3Connection.java:25) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
        at org.sqlite.jdbc4.JDBC4Connection.<init>(JDBC4Connection.java:24) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
        at org.sqlite.SQLiteConnection.<init>(SQLiteConnection.java:45) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
        at org.sqlite.JDBC.createConnection(JDBC.java:114) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
        at org.sqlite.JDBC.connect(JDBC.java:88) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
        at java.sql.DriverManager.getConnection(DriverManager.java:664) ~[?:1.8.0_172]
        at java.sql.DriverManager.getConnection(DriverManager.java:270) ~[?:1.8.0_172]
        at com.sk89q.worldguard.util.profile.cache.SQLiteCache.<init>(SQLiteCache.java:63) ~[?:?]
        at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:197) ~[?:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-2f3ed3b]
     
    No plugins premium
     
  2. Yes, you are right. That's an issue related to sqlite database.
    Plugin can't access to the database. Probably you have no permission to manage a database on Server.pro (idk how does it work).
    You should get an external database (u should find some service online) or buy a VPS and host the database on it.
    Or you could avoid the database use.
     
  3. Try to chmod the SQLite file and the folder to 777
     
  4. electronicboy

    IRC Staff

    Basically, your only option is to speak to server.pro about that one, which I really doubt they'd fix; if you're able to write quick plugins, you might be able to set a system property to try to control where the sqlite library is extracted to
     
  5. Guys, Thank's for read.
    it was an internal error in the server clock, that's why the database gave wrong updates, after the same "Server.pro" service removed the console access for a while. Thank you
     
Thread Status:
Not open for further replies.