Plugin Error

Discussion in 'Spigot Help' started by saphiria, May 28, 2015.

  1. saphiria

    Artist

    After all of this, and this my plugin still will not load. I have also learned that its only this plugin, KFA. When i start the server i get this error log.
    Code (Text):

    [16:13:24 ERROR]: Could not load 'plugins/KFA.jar' in folder 'plugins'

    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/j0ach1mmall3/kfa/Main : Unsupported major.minor version 51.0

        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot.jar:git-Spigot-6a6b839-b0e81a4]

        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot.jar:git-Spigot-6a6b839-b0e81a4]

        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot.jar:git-Spigot-6a6b839-b0e81a4]

        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:291) [spigot.jar:git-Spigot-6a6b839-b0e81a4]

        at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot.jar:git-Spigot-6a6b839-b0e81a4]

        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:528) [spigot.jar:git-Spigot-6a6b839-b0e81a4]

        at java.lang.Thread.run(Thread.java:695) [?:1.6.0_65]

    Caused by: java.lang.UnsupportedClassVersionError: com/j0ach1mmall3/kfa/Main : Unsupported major.minor version 51.0

        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.6.0_65]

        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637) ~[?:1.6.0_65]

        at java.lang.ClassLoader.defineClass(ClassLoader.java:621) ~[?:1.6.0_65]

        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) ~[?:1.6.0_65]

        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) ~[?:1.6.0_65]

        at java.net.URLClassLoader.access$000(URLClassLoader.java:58) ~[?:1.6.0_65]

        at java.net.URLClassLoader$1.run(URLClassLoader.java:197) ~[?:1.6.0_65]

        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.6.0_65]

        at java.net.URLClassLoader.findClass(URLClassLoader.java:190) ~[?:1.6.0_65]

        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot.jar:git-Spigot-6a6b839-b0e81a4]

        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot.jar:git-Spigot-6a6b839-b0e81a4]

        at java.lang.ClassLoader.loadClass(ClassLoader.java:306) ~[?:1.6.0_65]

        at java.lang.ClassLoader.loadClass(ClassLoader.java:247) ~[?:1.6.0_65]

        at java.lang.Class.forName0(Native Method) ~[?:1.6.0_65]

        at java.lang.Class.forName(Class.java:249) ~[?:1.6.0_65]

        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot.jar:git-Spigot-6a6b839-b0e81a4]

        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot.jar:git-Spigot-6a6b839-b0e81a4]

        ... 6 more


     
    @Cldfire @TxS_PRIME (thanks for the help you two)

    @j0ach1mmall3 @Blackfatrat @nfell2009 (you three worked on KFA...)
     
  2. I think you've compiled the plugin with a wrong java version...
     
  3. saphiria

    Artist

    Maybe... Ive kinda given up. :p
     
  4. Try compiling the plugin with Java 1.7 and run the server with Java 1.7.. Then it should work.
     
    • Informative Informative x 1
  5. saphiria

    Artist

    Okay, thanks for telling me!
     
  6. No problem :) Say if it doesn't work either.