Plugin to make a 1.8/1.9 compatible server?

Discussion in 'Spigot Help' started by dankpandameme420, May 14, 2016.

  1. Okay so I'm updating my server to 1.9.2 and I'm wondering if there's any plugin out there to enable players running 1.8 clients to come on the 1.9 server. (Just saying, ViaVersion doesn't work, it only allows 1.9 clients onto 1.8 servers, not the other way around.) ((Unless I'm missing something here of course.))
     
  2. There is no way to allow 1.8 clients onto a 1.9 server because 1.9 servers have features that 1.8 clients do not know how to handle.
     
    • Agree Agree x 1
  3. I believe this is not even possible with a protocol hack?
     
  4. You are correct. There is no way to tell a 1.8 client to handle things like dual wielding and new items
     
    • Winner Winner x 1
  5. ProtocolSupport is what you're looking for. Their plugin page is a bit outdated but check their jenkins.
     
    • Like Like x 1
  6. Alright, I'll try that first and see what I can do.
     
  7. Did it work?