plugin.yml error

Discussion in 'Programming' started by wexxew, Jul 7, 2015.

  1. why does it always give an error in the aliases line???
    Code (Text):
    name: Advanced
    author: Ab
    version: 0.9
    main: me.ab.advanced.main
    depend: [Vault]
    commands:
      shop:
        description: Opens a gui which gives to access to buy/sell items
         aliases: [buy]
     
  2. Do you even YAML? Dude, just look at it and common sense should tell you there bad formatting because there is one more space.
     
  3. This is why I say I am an "expert" in Plugin configuration/YAML XD

    To solve ur issue I think move ur aliases tab by 1 space. Every "tab" in YAML is 2 spaces. Never use tabs...
     
  4. Code (Text):
      description: Opens a gui which gives to access to buy/sell items
    aliases: [buy] [ /code]
    EDIT: Hmm it seems to not pasting pefectly anyways. Try aliases right down in the line of description ?
     
  5. Try remove depend: [Vault] i had some errors when i used that too.
     
  6. If you don't depend Vault then there's a chance that Vault will load before the plugin. That is when the plugin will give out a huge error.