Solved Plugin.yml

Discussion in 'Spigot Plugin Development' started by FiXed, May 27, 2016.

Thread Status:
Not open for further replies.
  1. So I was curious if there's a way to parse a fake plugin.yml before startup to basically tell Minecraft there's a plugin.yml of course not actually having one in there. The use for this is I'm trying to get the plugin.yml to export and the jar obviously has the plugin.yml but it's not showing it in there. It pretty much doesn't make sense so I'm just trying to figure out a way to parse a fake plugin.yml, the plugin.yml would still be in the jar but it would just be telling Minecraft where it is.. (Hope I explained that well xD)
     
  2. No you need the plugin.yml so bukkit knows which main class to load and what version and name to give it. If you are using maven (which is recommended) put the yml file in src/main/resources.
     
  3. Except the thing is the error doesn't make any sense, the plugin.yml is definitely in there.
    [​IMG]
     
  4. What kind of error are you getting?
     
  5. "Jar does not contain plugin.yml"
     
  6. Now it's saying this:
    Code (Text):
    27.05 03:25:09 [Server] INFO org.bukkit.plugin.InvalidPluginException: Cannot find main class `com.avrgaming.civcraft.main.CivCraft'
    27.05 03:25:09 [Server] ERROR Could not load 'plugins/CivCraft.jar' in folder 'plugins'
    and...
    [​IMG]
     
    #6 FiXed, May 27, 2016
    Last edited: May 27, 2016
  7. If it can't find it your package is most likely not relative to the plugin. You can check where everything is just by extracting your plugin.
     
  8. I've done it already and everything is there, might use Intellij for it's amazing Maven shading
     
  9. I would definitely recommend using Maven, it makes it so much easier for yourself and anyone else if you make it open source.
     
  10. That's what I'm gonna do
     
  11. re-export and re-upload.
    happens to me, I just do ^ and it works.
     
  12. This is what happens when HTML tries to write Java ;)
     
  13. kden
    Idk why it happens to me, just Eclipse I guess
     
  14. Ahhh, yeah that's the issue. You should look into InteliiJ :p
     
  15. Tried it, hate it.
     
    • Agree Agree x 1
  16. o_O
     
  17. Wow, just wow, i have never seen a person hates IntelliJ anyway XD, no argurment here, Everyones have their own opinion ;)

    *Mark thread as solved :p
     
  18. It's not solved, it still doesn't work and yes Intellij is bad, I'm trying to use maven to import commons.io and it's not actually importing it at all, in Eclipse it has no errors with that, could someone give me some pointers as to how to fix this?
     
  19. if you went with maven post your pom.yml
     
  20. Eh, figured it out
     
    #20 FiXed, May 27, 2016
    Last edited: May 27, 2016
Thread Status:
Not open for further replies.