Solved PluginMessageEvent is not a subclass of Event

Discussion in 'BungeeCord Plugin Development' started by WaffleMast3r, Jul 30, 2018.

Thread Status:
Not open for further replies.
  1. I try to fix this error and I have no clue how to do it. http://prntscr.com/kcs2fk
    [​IMG]
    I guess it's because my repo is wrong take a look at it too:
    Code (Text):

    ...
    <!--BungeeCord API-->
    <repository>
        <id>bungeecord-repo</id>
        <url>https://oss.sonatype.org/content/repositories/snapshots</url>
    </repository>
    ...
    <!--BungeeCord API-->
    <dependency>
        <groupId>net.md-5</groupId>
        <artifactId>bungeecord-api</artifactId>
        <version>1.12-SNAPSHOT</version>
        <type>jar</type>
        <scope>provided</scope>
    </dependency>
    <dependency>
        <groupId>net.md-5</groupId>
        <artifactId>bungeecord-api</artifactId>
        <version>1.12-SNAPSHOT</version>
        <type>javadoc</type>
        <scope>provided</scope>
    </dependency>
    ...
     
    Any idea how to fix this?
     
  2. NVM I'm just an IDIOT I import EventHandler from wrong location :D
     
    • Funny Funny x 1
Thread Status:
Not open for further replies.