Plugins are failing on my Multicraft installation

Discussion in 'Server & Community Management' started by freakdk, Feb 26, 2013.

  1. Hello

    I recently bought a dedicated server and decided to set up Multicraft on it.
    Now I run into these "permission" errors when running certain plugins.
    I haven't been able to find a solution to it on Google, perhaps anyone here would know what to do?

    I am using CentOS 6.3

    http://pastebin.com/34ydU2mp

    EDIT:
    Oh and I did of course check if this configuration would run on my own machine, and they did just fine.
     
  2. prplz

    Supporter

    Check the user running the server owns or has write permissions on the server directory.
     
  3. What command would I use for this?
    I am not much into Linux :)
     
  4. prplz

    Supporter

    I suggest you read up on linux filesystem permissions so you can get a good understanding of these concepts.
     
  5. Well. I did infact read up on it a bit, but struggled to figure out what I was doing wrong, I tried:
    chmod go+x /home/admin
    That's where my multicraft installation is running, also I am running everything as the root user.
     
  6. Sway

    Artist Supporter

    Back when i used multicraft, and was new to linux this helped me a lot. freakdk

    That's not a good idea.
     
    • Like Like x 1
    • Agree Agree x 1
  7. Been there, done that, not even the Support were able to help me.
    I decided it would be easier to just run without it.

    I am nolonger using the root user, as I decided to go research a bit finding out you were completely right.
    Running them through screens for now, it's worked out pretty well.

    Thanks.
     
    • Winner Winner x 1
  8. Sway

    Artist Supporter

    Running through screens is the way to go. ;)

    Panels are for nubs.
     
  9. I thought I would need the extra stuff Multicraft has, but it actually just made it much harder to configure the server.
    This way I can easily edit stuff through FTP and swap .jar files much faster.
    It doesn't even take that much getting used to.
     
  10. Sway

    Artist Supporter

    It really isn't too hard. :^)