Port 25565 Closed

Discussion in 'Systems Administration' started by Demonbarrage, Jun 12, 2019.

  1. You're run-of-the-mill issue.
    1.) Port-forwarded on the router. Allowed both TCP and UDP connections. Used a range (25564 - 25566).
    https://gyazo.com/920b92700158849f8d99e837abd58b05
    Other possible configurable options are on the left.
    2.) Created a rule in Advanced Firewall on Windows to allow any incoming connections through UDP or TCP ports 25564 - 25566.
    3.) Allowed any Java program to be allowed through my Windows Firewall
    https://gyazo.com/9a68350e97fdabe42bd554787b83b9e6
    3.) IPv4 address is configured correctly for the port-forwarding rule in my router. It is the same address that I get when I run /ipconfig all
    4.) Nothing is set on the "server-ip=" line in my server.properties file.
    5.) Have restarted the router to initialize changes, just in case.
    6.) The Minecraft server is started and running as I'm running these checks. As in, I am not testing to see if the port is open when the server has not been started. I am performing these checks when the server has been started using my "start.bat" file.

    I could try and disable Windows Firewall, the router's firewall, or try setting my computer inside a virtual DMZ (if NAT is causing the issue) but I'd rather not for security reasons.

    CanYouSeeMe and what'smyIP can't see any services running on port 25565.

    Any suggestions? You can talk nerdy to me, I'll understand it.

    (Posted this issue in Spigot Help but found out it might have been the wrong place, so posting here.)
     
  2. You have tried:
    1) A fresh install of the Minecraft Server.
    2) Tried a different port (Like 25566 just to see if that can be seen from the outside).
    3) Seen if you could join your MC Server locally.
    4) Considered that some ISPs don't allow people to host services on their home internet.

    Edit: Removed discord link.
     
    #2 MaGiiK_PartyBoy, Jun 12, 2019
    Last edited: Jun 12, 2019
  3. Added.

    1.) Have not tried.
    2.) Originally I used a range in my port-forwarding rule and tried 25564, and it was also closed.
    3.) Yes. I can.
    4.) I think mine allows it.
     
  4. Solution just in case anyone else has this particular problem:

    I was setting the port-forwarding rule to reach the IP of my wireless adapter rather than the IP of my Ethernet adapter, disabling the wireless adapter fixed the issue.
     
    #5 Demonbarrage, Jun 12, 2019
    Last edited: Jun 13, 2019