Spigot Potion Perks | 1.8-1.14 [Inactive] 1.2.2

Buy and upgrade all 30 potion effects! Includes permissions, durations and cooldowns!

  1. Moozter submitted a new resource:

    Potion Perks | Supports 1.8-1.13 - Buy and upgrade permanent potion effects!

    Read more about this resource...
     
  2. Moozter updated Potion Perks | Supports 1.8-1.13 with a new update entry:

    1.1 - Added several configuration options

    Read the rest of this update entry...
     
  3. Moozter updated Potion Perks | Supports 1.8-1.13 with a new update entry:

    1.1.3 - Added 1.14 support

    Read the rest of this update entry...
     
  4. @Moozter Hi, found a startup error Spigot 1.14 (and also, the configs don't generate some features mentioned in the main page)
    Code (Text):
    [07:13:33] [Server thread/INFO]: [PotionPerks] Enabling PotionPerks v1.1.3
    [07:13:33] [Server thread/INFO]: 1.14 detected, using new colors.
    [07:13:33] [Server thread/ERROR]: Error occurred while enabling PotionPerks v1.1.3 (Is it up to date?)
    java.lang.NullPointerException: null
            at andy_.potionperks.Messages.setString(Messages.java:24) ~[?:?]
            at andy_.potionperks.FileManager.loadConfig(FileManager.java:530) ~[?:?]
            at andy_.potionperks.PotionPerks.onEnable(PotionPerks.java:27) ~[?:?]
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:352) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:416) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
            at org.bukkit.craftbukkit.v1_14_R1.CraftServer.enablePlugin(CraftServer.java:458) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
            at org.bukkit.craftbukkit.v1_14_R1.CraftServer.enablePlugins(CraftServer.java:372) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
            at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:440) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
            at net.minecraft.server.v1_14_R1.DedicatedServer.init(DedicatedServer.java:258) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
            at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:758) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_181]
     
    #7 LachGameZ, May 16, 2019
    Last edited: May 16, 2019
  5. Thanks for letting me know. This will be fixed in 1.2 which I'll be releasing later today.
     
  6. Moozter updated Potion Perks | Supports 1.8-1.14 with a new update entry:

    1.2 - Added perk tokens, new colors and bug fixes

    Read the rest of this update entry...
     
  7. Thank you very much :)
     
  8. Unfortunately the perks.yml file seems to still be missing prices, permissions and durations.
     
  9. The prices are set under levels. Permissions and durations are optional, so they won't generate in the config by default. You add them if you want them.
     
  10. Alright. I'll fix my file with the one included in the main page.
     
  11. Hey I installed this plugin and people werent able to log into the server. said it couldnt recognize their names. I love the looks of this plugin and I really wish I could use it! Please lmk what info you need to fix this
     
  12. What's the exact error? Also this plugin doesn't ever kick people, so it's probably either an incompatibility with another plugin or your server.