Solved Prefixes are not working with Essentials and GroupManager

Discussion in 'Spigot Plugin Help' started by Byte11, Jul 8, 2017.

  1. No matter what I do, it either shows a prefix that says [default] Byte11 or the the normal <Byte11> when I use the chat. I want it to say [Owner] Byte11 or [Visitor] Byte11. I've tried changing numerous settings but nothing works. Right now, I'm running EssentialsX, EssentialsChatX, EssentialsSpawnX, GroupManagerX, and Vault.

    When I use /list to see my rank, it shows this error on the console and "error: null" in game:
    https://pastebin.com/faUSFuiH

    Without Vault, it shows my rank as default. There was no change to the prefixes other than that after adding Vault.

    My Essentials config:
    https://pastebin.com/nWj60qCG

    My GroupManager groups config:
    https://pastebin.com/YK8gyj1L
     
  2. check the config !
     
  3. The essentials config? What's wrong with it? Could you be a little more specific?
     
  4. Update: Commands like /spawn are having trouble on non-opped players. According to the errors, the problem seems to be Vault as well. Does anyone have a fix for Vault or a newer version that what's on bukkit?
     
  5. have you done /pl to check if pex is green?
     
  6. As the title and post say, I'm not using pex, I'm using GroupManager. GroupManager, Vault, and all my other plugins are green.
     
  7. Are Vault, Essentials, and Group Manager all for the same Minecraft version and for the same version as your server?
     
  8. They're all the latest version and my server is too. I just started making it. I should note that when I say Essentials and GroupManager, I mean GroupManagerX and EssentialsX.

    I followed the links provided here:
    https://www.spigotmc.org/wiki/spigot-1-12-plugin-compatibility-list/

    I assume they're up to date.
     
  9. Do you get any errors in the startup log? If so please upload the startup log to pastebin and reply to me.
     
  10. I've added a few more plugins since I started this thread, but they've had no problems (I'm slowly adding and updating all my plugins from 1.7). Anyways, here is the startup log:
    https://pastebin.com/JPdDXG59
     
    • Like Like x 1