Prefixes not working... Atall...

Discussion in 'Spigot Plugin Help' started by cyrildorricott, Jun 22, 2018.

  1. We recently switched to UltimateChat... Then switched back due to the amount of bugs we were finding and incompatibility with other plugins we had. However in the process of switching, we uninstalled essentialschat and removed the format: 'format' and now cannot get the format to work again, we have tried {group} which just showed the group name and {prefix} which just showed '{prefix}.' I vaguely remember there being something along the lines of {group_prefix} or {groupprefix} - both of which did not work.

    (Our permissions plugin is PermissionsEx and there are no other plugins handling the chat, and we have Vault installed)

    This is my essentialschat config:
    Code (Text):
    ############################################################
    # +------------------------------------------------------+ #
    # |                   EssentialsChat                     | #
    # +------------------------------------------------------+ #
    ############################################################

    # This section requires the EssentialsChat.jar to work.

    chat:

      # If EssentialsChat is installed, this will define how far a player's voice travels, in blocks.  Set to 0 to make all chat global.
      # Note that users with the "essentials.chat.spy" permission will hear everything, regardless of this setting.
      # Users with essentials.chat.shout can override this by prefixing text with an exclamation mark (!)
      # Users with essentials.chat.question can override this by prefixing text with a question mark (?)
      # You can add command costs for shout/question by adding chat-shout and chat-question to the command costs section."
      radius: 0

      # Chat formatting can be done in two ways, you can either define a standard format for all chat.
      # Or you can give a group specific chat format, to give some extra variation.
      # For more information of chat formatting, check out the wiki: http://wiki.ess3.net/wiki/Chat_Formatting

      format: '{deluxetags_tag} {prefix}{DISPLAYNAME}&f: {MESSAGE}'
      #format: '<{DISPLAYNAME}> {MESSAGE}'
     
      group-formats:

     
    which produced:

    http://prntscr.com/jy0nq7

    Thank you for your time,
    ~ Eejay
     
    • Agree Agree x 1
  2. I mean thanks, but I did check the wiki - that's how i got to {GROUP} and as I said above, that didn't work...
     
  3. You can try this '{DISPLAYNAME} &7»&r {MESSAGE}' to modify the chat format.


    Here it's my configuration and it works.

    Code (Text):
    format: '{DISPLAYNAME} &7»&r {MESSAGE}'
      #format: '&7[{GROUP}]&r {DISPLAYNAME}&7:&r {MESSAGE}'

      group-formats:
      #  Default: '{WORLDNAME} {DISPLAYNAME}&7:&r {MESSAGE}'
      #  Admins: '{WORLDNAME} &c[{GROUP}]&r {DISPLAYNAME}&7:&c {MESSAGE}'
     
  4. I have {DISPLAYNAME} as well, what permission plugin are you using?
     
  5. PermissionsEx but it also works with GroupManager
     
  6. hmm that's odd my {DISPLAYNAME} only shows the user's name
     
  7. Do you have EssentialsChat in your server ?