Solved Premium resource placeholders broken all of a sudden

Discussion in 'Community Feedback and Suggestions' started by DotRar, Jun 29, 2020.

  1. Hi all, in my latest plugin update, my premium resource variables (i.e. %%__USER__%%) randomly broke - they just aren't being replaced. Everything has been fine for the past 2 years, but all of a sudden, they've broken with my latest update (I've tried republishing it). I've had multiple users report the issue, and also got my friend to download and send me a jar for me to decompile, and as you can see, even a simple usage isn't being replaced:
    [​IMG]
    Cheers.
     
    #1 DotRar, Jun 29, 2020
    Last edited: Jun 30, 2020
  2. md_5

    Administrator Developer

    • You started zipping the resource
    • You compiled against a new java version
    • Your obfuscator or compiler is broken
    It's gonna be one of these, we've made no changes
     
  3. 1- Resource is still a jar
    [​IMG]

    2- Chucked it in a java class file analyzer, can confirm it's still Java 52.0. Been compiling against Java 8 all along

    3- I'll try uploading without obfuscation (it's only proguard), but I doubt it since I don't have anything touching strings at all
     
  4. Uploaded without obfuscation, can confirm its still not working:
    [​IMG]
    (also jar that friend downloaded)
     
  5. md_5

    Administrator Developer

    Code (Text):
    java.lang.IllegalArgumentException: Unsupported class file major version 58

     
    You have at least some Java 58 versioned classes in your jar
     
  6. Seems like 1 tiny module of my project was being compiled with Java 14, as I recently installed Java 14 and hadn't explicitly specified my targetCompatibility in my build.gradle to build with Java 8.

    My bad, cheers.