Problem starting server, error?

Discussion in 'Spigot Help' started by Krazey_, Jun 14, 2016.

  1. What's wrong?

    http://pastebin.com/UGHjiaRD

    So the server was on 1.8.8 and I changed the JAR file to the one I downloaded: spigot-1.9.2.jar

    Then I deleted all the files because of this error except the plugins folder and world, then I ran it again and I got the same error. Any help with this?!
     
  2. I'll tell you something about the errors. You start of with the type of error and then sometimes a short description of it and then a stack trace. A stack trace is a list of classes from where the error comes from. In the class paths you can normally see what Plugin caused it.
    This is a piece I got from your log. Here you can see that the Plugin no cheat plus was giving an error.
    Code (Text):
    java.lang.NoSuchMethodError: org.bukkit.Bukkit.getOnlinePlayers()[Lorg/bukkit/entity/Player;
        at fr.neatmonster.nocheatplus.players.DataManager.onEnable(DataManager.java:390) ~[?:?]
        at fr.neatmonster.nocheatplus.NoCheatPlus.onEnable(NoCheatPlus.java:746) ~[?:?]
    When a Plugin is giving an error, you should see if the Plugin is actually up to date with you spigot version. In this case a lot of your plugins should be updated.
     
    • Like Like x 1
  3. Also don't use TeamCity version of Essentials anymore use EssentialsX it is kept up to date
     
    • Like Like x 2
  4. Sorry guys I realized I was updating a 1.8 server to 1.9 without even thinking about updating the plugins. Thanks for the help though!