Problem With Compiling In Eclipse

Discussion in 'Spigot Plugin Development' started by stanjg, May 6, 2017.

  1. Hey guys,

    I'm creating a plugin and I was working on it but suddenly when I tried to compile this happened:
    [​IMG]
    Classes are blurred because it's a pretty private and secret project I'm working on.

    It basically gives that error for every class, I looked it up and someone said you have to clean your project up (Project -> clean) However that didn't work.

    I then copied all the code and backed it up, I deleted the project, created a new one and copied all the files back. The errors are still showing....

    I hope some of you can help :)
     
  2. Is your workspace in a directory that Eclipse doesn't have access to? Like Program Files?
     
  3. No, it's in a folder on the root of my second harddrive
     
  4. Can you still try to just compile it on your PC's desktop?
     
  5. Still doesn't work. I don't think it's the problem, because I can open and read and edit the classes in eclipse so it does have acces.