Problems when i upload map - session lock

Discussion in 'Server & Community Management' started by Ricardo Diaz, Sep 4, 2013.

  1. Hello friends, I have a server, and installed multicraft and bungeecoord it. But I tried to upload the map to my HUB and start the server I get an error something like session lock. Below is the full error with the pastebin.

    Someone please tell me what to do? Thank you very much!

    http://pastebin.com/gJjQKm4J
     
  2. However the server is off, I do upload and then start the server then this error appears. I have another PVP server I run, but has nothing to do with this.
     
  3. jtaylor69

    jtaylor69 Retired Moderator
    Retired

    Delete the session.lock file within the world folders.
    Once done, try starting your server.
     
  4. I've tried the same error appears: (
     
  5. joehot200

    Supporter

    Does the "Hub" server have access to the session.lock file? Try using the "su" command before running the server, or "sudo -s".
    This error occurs when the session.lock file either doesn't exist, or the server cannot access it.
     
    • Disagree Disagree x 1
  6. I believe it is permission error, because each time I need to edit a file in folders that have multicraft by permission. What is the command to me for permissions permanent multicraft?
     
  7. joehot200

    Supporter

    Try not using multicrap and just using SSH to run the server.
     
    • Disagree Disagree x 1
  8. I've tried, updated the spigot and it did not work, I tried with bukkit and also gives the same error!
     
  9. Got it, had to give permission to the map folder in ssh.
     
  10. joehot200

    Supporter

    lol. i suspected that was the problem ;)
     
  11. How to get permission