Solved Problems with lag and redstone

Discussion in 'Spigot Plugin Help' started by Laguna, Jan 11, 2020.

  1. Hello good afternoon, I am desperate with a problem with my server that I don't know how to fix it. Before describing the problem I will give you data from the server:

    Spigot version: 1.14.4
    Server: shockbyte 3Gb
    No. Plugins: 26 (https://i.ibb.co/nM8D16z/plugins.jpg)

    The problem I have is that although we are 3 or 4 users normally on the server, at some times it drops to 15 TPS, and the ram memory of the server is free more than 50%.

    It also happens to me that sometimes the redstone stops working, the switches or the plates do not work. It happens on all the maps I have, and suddenly it works again, in random moments.

    Any ideas that can be and how to solve it ?. Excuse my English, I'm using a translator.
     
  2. Hello,

    Could you please perform a timing, to see what’s causing lags ? Just type /timings on, then wait a moment of lag, and type /timings paste.
     
  3. First of all thanks for answering ^^. Say that I have increased the server to 4Gb to see if it is fixed.

    I did the timing command, the result is this:

    https://timings.spigotmc.org/?url=iravatupay
     
  4. Looks like it’s the plugin AConomy which is causing lags issues : a task repeated every 6000 ticks so each 300 secondes, so each 5 minutes. Maybe try to remove this plugin.
     
  5. I will remove it, thank you very much, to see if I find any similar plugin :). Very friendly!