Spigot ProtectionStones [Updated for 1.13 - 1.17 + WG7] 2.8.5

The easiest grief prevention method that players will enjoy!

  1. Okay, I did just that but it gives me nothing.
     
  2. Did you use the command /ps give?
     
  3. Ok so I added:
    protection:
    mykit:
    delay: 1
    items:
    - 272 1
    - /get {player} 64
     
  4. no, you need to change the values

    /ps give {player} 64
     
  5. And it doesn't still work, it gives me nothing this time.
     
  6. I tried with give too, but get afterwards.
     
  7. Could you write me the correct format? I might do something wrong
     
  8. Replace your /get with /ps give {player} 64
     
  9. Still nothing...
     
  10. Code (YAML):

    kits
    :
      mykit
    :
        items
    :
         - /ps give 64 {player}
     
     
  11. Ok, I give up. it broke all the other kits and gave me the default dtools and notch thing
     
  12. I tried again, now it kinda works but it shows that that kit is inproprely defined, contact an administrator
     
  13. Very, very nice plugin! Been using it and I'm really glad to find that it's not fully command-based.
    I like placing blocks, using items instead of writing commands.

    Anyways, one tiny feature recommendation.
    Please add "amount" to /ps give and /ps get
    Would be nice to get/give more than 1 block.
     
  14. I think you should ask EssentialsX support on how to define a kit
     
  15. Actually /ps give does have that feature: /ps give [block] [player] [amount]

    https://github.com/espidev/ProtectionStones/wiki/Commands
     
  16. Hello! Today updated protectionstones and i have this in my console
    Code (Text):
    [09:17:29] [Craft Scheduler Thread - 26 - ProtectionStones/WARN]: [WorldGuard] Failed to execute queries
    java.sql.SQLException: statement is not executing
        at org.sqlite.core.CoreStatement.checkOpen(CoreStatement.java:55) ~[patched_1.16.5.jar:git-Tuinity-"7734ef0"]
        at org.sqlite.core.CorePreparedStatement.batch(CorePreparedStatement.java:102) ~[patched_1.16.5.jar:git-Tuinity-"7734ef0"]
        at org.sqlite.jdbc3.JDBC3PreparedStatement.setString(JDBC3PreparedStatement.java:411) ~[patched_1.16.5.jar:git-Tuinity-"7734ef0"]
        at com.sk89q.worldguard.util.profile.cache.SQLiteCache.executePut(SQLiteCache.java:137) ~[?:?]
        at com.sk89q.worldguard.util.profile.cache.SQLiteCache.putAll(SQLiteCache.java:118) ~[?:?]
        at com.sk89q.worldguard.util.profile.cache.AbstractProfileCache.put(AbstractProfileCache.java:37) ~[?:?]
        at com.sk89q.worldguard.util.profile.cache.SQLiteCache.put(SQLiteCache.java:47) ~[?:?]
        at dev.espi.protectionstones.ProtectionStones.lambda$onEnable$1(ProtectionStones.java:608) ~[?:?]
        at org.bukkit.craftbukkit.v1_16_R3.scheduler.CraftTask.run(CraftTask.java:100) ~[patched_1.16.5.jar:git-Tuinity-"7734ef0"]
        at org.bukkit.craftbukkit.v1_16_R3.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:58) ~[patched_1.16.5.jar:git-Tuinity-"7734ef0"]
        at com.destroystokyo.paper.ServerSchedulerReportingWrapper.run(ServerSchedulerReportingWrapper.java:22) ~[patched_1.16.5.jar:git-Tuinity-"7734ef0"]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_275]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_275]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_275]
    How can I resolve this problem?
     
  17. This seems to be a worldguard error, does it occur if you restart the server?
     
  18. Yep. I changed my dedicated server and moved all files to new one.
     
  19. have you seen it happen on more than one reboot (try rebooting again)? I'm a bit unsure of this because it seems to be a worldguard issue
     
  20. It is possible to set plot limits for individual ranks?