Protocol hack help needed

Discussion in 'Spigot Help' started by xXSquidMcXx, Apr 28, 2017.

  1. Hi,
    I want to allow 1.7.10+ users on my 1.8.8 server.
    How can I do this?

    Thanks,
    -Sam
     
  2. From my understanding, that only works the other way around. For example, you can only allow players from a higher version to join your server. You can't allow players of a lower version to join a server of a higher version. The lower version clients would freak out about all of the unrecognized things on the server.
    There is a chart on the ViaVersion plugin page that explains it. There is ViaBackwards for 1.9 and 1.10.
     
  3. Protocol Support works with ViaVersion on a 1.8.8 server to allow 1.7 -> 1.11
     
  4. You're wrong with that one, ProtocolSupport let you (the client) play into versions lower than the server version and ViaVersion does the opposite.
     
    • Agree Agree x 1
  5. His question ^
    I can assure you I'm not wrong. A Spigot 1.8.8 server with ViaVersion and Protocol Support v4.23.dev allows for 1.7 -> 1.11 support, lol.
     
  6. Yeah, it does, it's just that I didn't see where you said "with ViaVersion", sorry for the confusion.
     
  7. Installed that and it doesn't work.
    Just crashes my server on startup.
     
  8. Because the latest ProtocolSupport version is only for 1.11.2.

    If you want ProtocolSupport for 1.8.8, you will need to compile it using ProtocolSupport's source, Shevchik isn't updating PS 1.8.8 anymore because... well, 1.8.8 is obsolete at this point.
     
  9. I used an old one.
     
  10. If you downloaded it from the "Version History", then you downloaded a version for 1.9.

    If you downloaded it from Shevchik's dev builds, then you downloaded a version for 1.10.
     
  11. I got that dev build one, which didn't work.
     
  12. Use ProtocolSupport and ProtocolLib

    Make sure you get the right versions.
     
  13. Can you get right version.
     
  14. What version is your server running currently?
     
  15. Do you have the error so we can look at it?
     
  16. 1.8.8 spigot