ProtocolHack 1.8-1.9?

Discussion in 'Spigot Help' started by Brunno, Jun 12, 2016.

  1. Have any version of spigot protocolhack with 1.9 players join in 1.8 servers? (I don't want do use ViaVersion, but if don't have any alternative, I will do it.)
     
  2. Whats wrong with viaversion...
     
  3. Im using it right now to let 1.10 clients join.
     
  4. ViaVersion supports 1.10 clients?
     
  5. Yes
     
    • Agree Agree x 1
  6. can you send me the 1.8-1.9.4 spigot?

    I don't wanted to use ViaVersion because it's a plugin, and I have a bad experience with protocolhack plugins.

    Now I will use it to put the 1.8/1.9/1.10 support on my server.
     
  7. Trust me viaversion has no block lag or any type of lag like other protocolhacks to.
     
    • Agree Agree x 1
  8. Ok, fuck off the other protocolhack plugins, can you send me the 1.8-1.9.4 spigot?
     
  9. Your question was answered, used ViaVersion. I've been using it for months and never have issues. I suggest updating it frequently though.
     
    • Agree Agree x 1
  10. my fucking question is not answered, I want to get 1.8-1.9.4 spigot because i want to add 1.10 compatbility to a 1.8/1.9 server, can you understand me?
     
  11. dont go swearing =(
     
    • Agree Agree x 1
  12. No one is going to help you if you say:
    So I wouldn't be the one saying:
    Because it has been:
     
    • Winner Winner x 1
  13. Okay tough guy, this is a Minecraft forum.
    The solution to your question is ViaVersion, so yes, your question is answered.
     
    • Agree Agree x 1
  14. No men, I'm questioning if have a SPIGOT VERSION and not a PLUGIN to provides me a protocolhack

    Sorry for the bad words.
     
  15. If you want support with 1.8, 1.9, and 1.10, put your server on spigot 1.8.(whatever you want) and get ViaVersion 0.9.2.. It works for me. Also, you gotta make it custom if you want a spigot version.
     
  16. On ViaVersion page, says: You can use a 1.8-1.9.4 server and allow 1.10 to connect.

    but I will try your method, thanks.

    It's solved. I will try post this same topic in a Brazilian community, for to get a best comunication
     
  17. @Brunno to clear up what they mean by 1.8-1.9.4, they are talking about version 1.8,1.8.1,1.8.2,1.8.3,1.8.4,1.8.5,1.8.6,1.8.7,1.8.8,1.8.9,1.9,1.9.1,1.9.2,1.9.3,1.9.4. The '-' is to shorten it.
     
  18. Actually only 1.8.8 is officially supported
     
  19. The only difference with 1.8 and 1.9 plugins is that they changed getOnlinePlayers();.. It's a easy fix.. I could just make a plugin that fixes that by overwriting it and changing the code to detect what version and what method XD.