Spigot ProtocolLib 4.7.0

Provides read/write access to the Minecraft protocol

  1. The plugin supports j16 allready. You need to havw Build Version minimum of 499 of it. You get it from the git of procolllib (you find link on plugin descriptionor klick here:
    https://ci.dmulloy2.net/job/ProtocolLib/lastSuccessfulBuild/
    It just does not support spigot 1.17 jet.
    Nay this support come with Build 506

    And by the way..1.17 forced all to use minimum java16 ;) Because its dependency for mc 1.17 ( not the 1.8via version sh** that fakes to be 1.17) even the mc client installs its own java16 if you dont have seperatly installed it. Mc 1.17 vanilla allread comes with java 16.0.1 x64 - see F3 ingame if u defined no special java folder)
     
    #1381 CloudeLecaw, Jun 11, 2021
    Last edited: Jun 11, 2021
    • Like Like x 1
    • Friendly Friendly x 1
  2. Read the front page of the Plugin!
    Btw did you mean every developer can spend 100% of her lifetime to develope?
    Give him the time he need to make it usable!
     
    • Friendly Friendly x 1
  3. Please update the plugin for 1.17! tons of plugin's won't work without ProtocolLib
     
  4. inb4 everyone asks "pls 1.17 support" oof. Please be patient guys!
     
    • Agree Agree x 1
    • Friendly Friendly x 1
  5. A little doubt, I have tried this plugin with 1.17 and it does not work, do you plan to give it compatibility with 1.17?
     
    • Friendly Friendly x 3
    • Agree Agree x 1
  6. im having the error:java.lang.NoClassDefFoundError: Could not initialize class com.comphenix.protocol.events.PacketContainer and when I disconnect, and it disconnects me for this very often. anyone got something to help with that?
     
  7. Current version dose not work with Paper 1.17 server.
    22.06 09:18:43 [Server] INFO Enabling ProtocolLib v4.6.0
    22.06 09:18:43 [Server] ERROR ******************************************************
    22.06 09:18:43 [Server] ERROR *** ProtocolLib does not support plugin reloaders! ***
    22.06 09:18:43 [Server] ERROR *** Please use the built-in reload command! ***
    22.06 09:18:43 [Server] ERROR ******************************************************
    22.06 09:18:43 [Server] INFO Disabling ProtocolLib v4.6.0
     
  8. Very weird.. have you tried going back a version, maybe update your paper 1.17 jar
     
  9. You need to use the devbuild from the frontpage only protocollib 4.7.0-SNAPSHOT is compatible with spigot 1.17
     
    • Like Like x 1
  10. I'm running the newest dev build of protocolLib but the ecoEnchants plugin that i have still isnt working. I was told there that i needed to wait for this plugin to update. any suggestions? it uses the /enchant command and adds new enchantments, it should work based on what i know of the plugins, just waiting on this to update
     
  11. Can you make it for 1.17?
     
  12. Mhh, if protocolLib activ on paper 1.16.5 and i try a // command (for example //set stone) i get kicked from the server with an error. (I activate only WE and PL so a am sure only this two plugins are aviable for this error) DecoderException java blablabla OutOfBoundsException io.netty.handler.codec.MessageToMessageDecoder:98

    *we use Bungeecord,
     
    #1394 EasySIX, Jun 25, 2021
    Last edited: Jun 26, 2021
  13. Did you even bother to look at the Overview page?
    "If you're running 1.17, use the latest dev build."
     
    • Like Like x 1
    • Funny Funny x 1
  14. Im running the dev build on the Paper 1.17 server and it is working no errors in the console.
     
    • Friendly Friendly x 1
    • Friendly Friendly x 3
  15. Hello, I have an Aternos server and the ProtocolLib plugin is not updated for 1.17 in Aternos and neither are the dev builds in Aternos

    When I try to download version 4.6.0 in Aternos it gives me a lot of errors, because this version which is the last one found in Aternos is not updated to 1.17

    My request is to add the ProtocolLib for 1.17 in Aternos

    Aternos (aternos.org) is a free server host
    @dmulloy2
     
  16. Not updated for 1.17 then?
     
  17. SlimeDog

    Moderator Patron

    Read back two messages. The first dev build that supported 1.17 was released on Jun 15, five days after Spigot 1.17. Given that Spigot 1.17.1 was released just two days ago, you might expect a few more days for the dev team to package a 1.17.1-compatible ProtocolLib.
     
    #1400 SlimeDog, Jul 8, 2021
    Last edited: Jul 8, 2021