Spigot ProtocolSupport 4.28

Adds 1.12-1.4.7 clients support to your spigot 1.12.2 server

  1. Greetings

    CorruptedFrameException : Empty Packet! @ net.md_5.bungeeprotocol.Varing21FrameDecoder:34

    Spigot 1.8.7

    BungeeCord Server
    FIX IT
     
    • Optimistic Optimistic x 1
  2. Not a protocolsupport bug.
     
  3. Can't get it to work in any version.

    I tried 1.8, 1.8.3 and 1.8.8 with latest update and it doesn't allow anyone to join.

    I tried with those versions and the latest builds and it didn't allow anyone to join as well.

    I tried to delete the whole server and starting it again with the plugin and it didn't work.

    I got sometimes this error: http://prntscr.com/7yz2v9 and other times only: http://prntscr.com/7yz2pb
     
    #83 JRoviraa, Jul 30, 2015
    Last edited: Jul 30, 2015
  4. You need spigot 1.8.8 1 version before the latest
     
  5. 1.8 doors don't allow 1.7 clients to walk through them, I imagine their client thinks of it as a solid block.
     
  6. You need the latest dev build for spigot 1.8.8
     
    • Like Like x 1
  7. i am using lasttdev and 1.8.8, it say when login with 1.7.2
    [18:22:04 INFO]: Malachiel lost connection: Internal Exception: java.io.IOException: Error while writev(...): Broken pipe
     
  8. Can you make protocol only for 1.7.x versions? Cause i want 1.8.8 server with 1.7 versions, and your plugin worked before for me, now just crashing with 1000 errors
     
  9. Latest dev build works well on spigot 1.8.8 but for all 1.8.* and 1.7.* clients. Older versions like 1.5.* 1.6.* dont work. Im not sure it is protocolsupport or protocolsupportbungee cause :p
     
  10. Btw, I think ppl would like 1.7 only
     
  11. Works for 1.8.8?
     
  12. --> What did you do to solve your issue?
     
  13. Spigot 1.8.8 and latest dev build
     
  14. Latest dev Error: 04.08 21:07:03 [Disconnect] User /IP has disconnected, reason: Internal Exception: java.lang.NoSuchFieldError: hostname
     
  15. Latest dev build is only for spigot 1.8.8
     
  16. This server is running CraftBukkit version git-Spigot-6c9b0a1-de5c261 (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT)
     
  17. This is not the latest spigot 1.8.8. You need the latest build of spigot 1.8.8
     
    • Useful Useful x 1
  18. Is it possible to mention the build number or exact version here. So if someone reads this in 3 weeks he will not know which one was meant by 'latest' version at the time this has been written. I had also issues finding a 1.8 Spigot version which was running without error message as it was not clear which version of the plugin works with which version of Spigot (only 'latest' which was confusing).