Spigot ProtocolSupport 4.28

Adds 1.12-1.4.7 clients support to your spigot 1.12.2 server

  1. does not work with 1.8.3 paper spigot? I tried using it as a plugin in plugins folder and it just shut down my server as soon as it started.
     
  2. Only latest 1.8.8 spigot build is supported.
     
  3. Can you make 1.8.3 paperspigot support? I'll pay $2 - 5 for that.
     
  4. No, i don't have time to port this to other platforms and other versions.
     
  5. =/ do u know of other alternatives to your plugin than?
     
    • Like Like x 1
  6. when will the stable version 4.20?
     
    • Agree Agree x 1
  7. juy

    juy

    This is a good plugin.But why I can't use it on Spigot1.8.7?
     
  8. #111 Shevchik, Aug 19, 2015
    Last edited: Aug 19, 2015
  9. Not working for 1.8.8 unfortunately.
    Also seems to cause some issues with AuthMe and ask already registered players to /register again... Any way around this?
     
    #114 d1One, Aug 25, 2015
    Last edited: Aug 25, 2015
  10. Spigot 1.8.8 + Authme 5.0 DEV + Protocolsupport = work
     
  11. Well not for me. I tried it all. 1.8.7, 1.8.8, latest Authme Dev version, latest stable.

    With latest 1.8.8 and Authme Dev people cant even connect. (and i do have the bungee version installed.)

    27.08 14:24:40 [Disconnect] User /192.99.32.32:52824 has disconnected, reason: Internal Exception: java.lang.NoSuchFieldError: b
    27.08 14:24:30 [Disconnect] User /192.99.32.32:38981 has disconnected, reason: Internal Exception: java.lang.NoSuchFieldError: b
    27.08 14:24:29 [Disconnect] User /192.99.32.32:54960 has disconnected, reason: Internal Exception: java.lang.NoSuchFieldError: b
    27.08 14:24:24 [Disconnect] User /192.99.32.32:39658 has disconnected, reason: Internal Exception: java.lang.NoSuchFieldError: b

    Only way it works (for me at least) is with 1.8.7 but, it creates many problems for Authme.
    What would be nice is a list of compatible versions, Bungee version, Spigot version, Authme version. Thousands of servers use Authme.
    I would happily buy this if it was a premium resource, as long as it works.

    ***EDIT*** UPDATE:

    So. I am now using the latest bungee and latest Authme (dev) and spigot 1.8.7 (1.8.8 refuses to work) Things appear to work but a few players can't connect, they just wait forever at log in and eventually time out.
     
    #116 d1One, Aug 27, 2015
    Last edited: Aug 27, 2015
  12. You know, there is a link to dev builds of this plugin.
    Guess what you should have done first?
     
    • Informative Informative x 1
  13. Just tried it. It does fix the 1.8.8 issue, but a lot of players still get timed out and cant log in.
    It might be some sort of domain problem, because if they use the real numeric ip they log in fine, but using the domain name they cant. (mc.futurepvp.com)

    Here is my dns settings in case it helps somehow, or maybe you can point in something that can be tweaked to make it work (altho i never had any problems)

    [​IMG]
     
  14. ProtocolSupport not allowed use 145:1, and 145:2. (1.8.8)
     
  15. I am using lastest spigot 1.8.8 and I can not connect with any client