PvP Not Working

Discussion in 'Spigot Plugin Help' started by BenBeast, May 31, 2016.

  1. Hello,

    I have a KitPvP server and have two worlds which are loaded in and being used. PvP is enabled in all of the worlds however it doesn't work in one of the worlds. It's enabled in multiverse and so I really don't know what else I could check in order for it to work.

    A screenshot of all my plugins: removed

    Any suggestions would be appreciated.

    Thanks, Ben.
     
    #1 BenBeast, May 31, 2016
    Last edited: Dec 18, 2016
  2. Have you used world guard? If so, /rg flag <region name> PvP allow
     
  3. I did that. I even did it for the global region. I'm going to try fiddling around with the priorities. Thanks for the suggestion though.
     
  4. Ok. I disabled WorldGuard. Still can't PvP. I now know for sure it isn't WG :/
     
  5. I am having this exact same problem.
    No lie.
    I messed with world guard and even checked server.properties... :(
     
  6. mathhulk

    mathhulk Retired Moderator
    Retired

    Make sure that spawn-protection is not somehow overriding pvp rules.
    Also, make sure that when you enable pvp using Multiverse, you use the following command:
    ./mvm set pvp TRUE
     
  7. Code (Text):
    spawn-protection=4
    I will set the pvp when I get back on my PC
     
  8. ok so i know that this is the last resort but try to do a clean sweep of MV and all other world editing plugins. but before you do so, please make a backup of the plugin data. ( so then if anyone gets mad they only have themselves to be mad at.)