Spigot PvpDuels - Challenge your players! 0.6

PvpDuels allows you to create pvp arenas without complicated set-up!

  1. darkreval submitted a new resource:

    PvpDuels - Challenge your players! - PvpDuels allows you to create pvp arenas without complicated set-up!

    Read more about this resource...
     
  2. Same problem here. Commands do not work. Plugin does load and config is made.
     
  3. zKyu

    Patron

    I think a good thing for you to do is for them to do /duel and it puts them like in a waiting list until someone else does /duel and then it tps them to a arena. Because this makes it a lot easier for the players. If the command is fixed this way i will be downloading it.
     

  4. I was testing this on 1.7.10,going to fix this asap

    When this crash happened? Post your config,


    FIXED! YOU CAN NOW DOWNLOAD UPDATE.
     
    #6 darkreval, Jan 22, 2016
    Last edited: Jan 22, 2016
  5. Maybe good thing will be if GUI with arenas will open after executing /duel? What do you think?
     
    • Like Like x 1
  6. Gui is nice! or so /duel PlayerName and the PlayerName make /duel Accepte and TP in a free Arena
     
    • Agree Agree x 1
  7. zKyu

    Patron

    That would be great. Also does the plugin save the inv that the player has and the xp and give him a kit that the config has made? then when they die it tps them back to where they were at and gives everything back they had?
     
  8. Inv restore feature is coming soon.
     
  9. Uso la versión 1.8.8 y no me funciona.

    Error:
     
  10. You need java 1,8
     
  11. Teleport on Setspawn1 ans 2 not work and This Error http://pastebin.com/XiQqGeTm When i add no Items to the Arena its work. Pleas add: Save all the Player Stuff in Inventory /duel saveinv <arena> The things you get then when it starts
     
    #17 BukkitFAQ, Jan 25, 2016
    Last edited: Jan 25, 2016
  12. Hi! When battle end arena all time full and other players cant play. I restart my server and arena work normal. But before 1 duel arena again be full.
    Your plugin very nice but i have some problem and i sad.
    And 1 have 1 new error: Could not pass event InventoryClickEvent to PvpDuels v0.5 Minox
    org.bukkit.event.EventException
    Spigot 1.8.8

    My english very bad becouse im russian sorry!
     
    #18 IceTroll, Jan 26, 2016
    Last edited: Jan 26, 2016
  13. problem first try on install , wanna try this out man , can ya tell me anything ?

    [22:18:11 ERROR]: Could not load 'plugins/PvpDuels.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/darkreval/pvpduels/PvpDuels : Unsupported major.minor version 52.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-1.8.3.jar:git-Spigot-870264a-0a645a2]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot-1.8.3.jar:git-Spigot-870264a-0a645a2]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot-1.8.3.jar:git-Spigot-870264a-0a645a2]
    at org.bukkit.craftbukkit.v1_8_R2.CraftServer.loadPlugins(CraftServer.java:291) [spigot-1.8.3.jar:git-Spigot-870264a-0a645a2]
    at net.minecraft.server.v1_8_R2.DedicatedServer.init(DedicatedServer.java:199) [spigot-1.8.3.jar:git-Spigot-870264a-0a645a2]
    at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java:522) [spigot-1.8.3.jar:git-Spigot-870264a-0a645a2]
    at java.lang.Thread.run(Thread.java:745) [?:1.7.0_80]
    Caused by: java.lang.UnsupportedClassVersionError: me/darkreval/pvpduels/PvpDuels : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_80]
    at java.lang.ClassLoader.defineClass(ClassLoader.java:800) ~[?:1.7.0_80]
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.7.0_80]
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) ~[?:1.7.0_80]
    at java.net.URLClassLoader.access$100(URLClassLoader.java:71) ~[?:1.7.0_80]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:361) ~[?:1.7.0_80]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[?:1.7.0_80]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_80]
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354) ~[?:1.7.0_80]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.8.3.jar:git-Spigot-870264a-0a645a2]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.8.3.jar:git-Spigot-870264a-0a645a2]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_80]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_80]
    at java.lang.Class.forName0(Native Method) ~[?:1.7.0_80]
    at java.lang.Class.forName(Class.java:278) ~[?:1.7.0_80]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.8.3.jar:git-Spigot-870264a-0a645a2]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.8.3.jar:git-Spigot-870264a-0a645a2]
     
  14. Java 1.8 only