Bukkit Quality Armory 1.1.112

A quality gun plugin similar to CrackShot.

  1. zombie_striker updated Quality Armory with a new update entry:

    Added Dragunov

    Read the rest of this update entry...
     
  2. The Dragunov has been added!
     
  3. YES YES FINALLY
    Thank you very much!
     
  4. The dragunov model and the other models look a bit bulky and blocky, I can make some models in magicavoxel if you want and send them over?
     
  5. If you would like to contribute models for the guns, I could add them to the resourcepack.

    I've been planning to go back and update some of my original models, but bugfixes have taken up most of my time. Once the plugin is mostly stable, then I may go back to fixing some of the guns.
     
  6. Ok, Can you import models made in magicavoxel? If so then I can make some.
     
  7. Can you provide the texture packs fileļ¼ŸChinese IP can't visit the texture packs download address.
    Thanks
     
  8. I've have not heard of this program before. I don't think so, unless the exports made by that program are the same as the ones in the resoucepack (you can download the resoucepack and if you want to compare the models).

    The program I use for creating the models is MrCrayFish'sModel Creator. Below is a link to the site and a tutorial on how to use it:

    https://mrcrayfish.com/tools?id=mc#downloads



    You can find the resoucepack on the github pack (QualityArmory 1.6.zip).
     
  9. I don't like Mr.Crayfish's model creator, It's to blocky and hulky for gun textures. Try using the program that mineplex used for mine strike.
     
  10. zombie_striker updated Quality Armory with a new update entry:

    Added better checks. new bullet models!

    Read the rest of this update entry...
     
  11. I'm not sure which program mineplex uses, but for MrCrayfish's modeler, you can resize the blocks if you don't want it to be too blocky (which, based on what I've seen for mineplex, is exactly what they did; the voxels are small enough that you don't notice them)

    In this update, I resized the ammo. Though it is not perfect (if I had more times, I could have made the bullets more cylindrical), this shows that it can create good models.
     
  12. Ok, Well I'm going to make some models using magicavoxel, I'll send them over and you can convert them if possible, Ill only make one for testing.
     
  13. hello, I use your plugin, but it gives me a lot of lag when starting session for the download of the resource package, I have it disabled in configuration but anyway it is downloaded config in false no work
     
  14. Yeah, installing any server-requested resourcepack for the first time does create some lag. Once the resourcepack has been installed once, the lag should be managable.

    Anyway, if you still do not want the resource pack, are you setting "useDefaultResourcepack" and "sendOnJoin" to false?
     
  15. Getting a ton of this npe on console. Pretty much renders my console completely unusable. :(

    Running 1.1.48 and latest spigot 1.12.2.

    Code (Text):
    18.02 10:45:01 [Server] WARN java.lang.NullPointerException
    18.02 10:45:01 [Server] WARN at me.zombie_striker.pluginconstructor.HotbarMessager.sendHotBarMessage(HotbarMessager.java:90)
    18.02 10:45:01 [Server] WARN at me.zombie_striker.qg.Main.onClick(Main.java:1516)
    18.02 10:45:01 [Server] WARN at sun.reflect.GeneratedMethodAccessor303.invoke(Unknown Source)
    18.02 10:45:01 [Server] WARN at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    18.02 10:45:01 [Server] WARN at java.lang.reflect.Method.invoke(Method.java:498)
    18.02 10:45:01 [Server] WARN at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:302)
    18.02 10:45:01 [Server] WARN at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
    18.02 10:45:01 [Server] WARN at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:500)
    18.02 10:45:01 [Server] WARN at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:485)
    18.02 10:45:01 [Server] WARN at org.bukkit.craftbukkit.v1_12_R1.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:235)
    18.02 10:45:01 [Server] WARN at org.bukkit.craftbukkit.v1_12_R1.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:202)
    18.02 10:45:01 [Server] WARN at org.bukkit.craftbukkit.v1_12_R1.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:198)
    18.02 10:45:01 [Server] WARN at net.minecraft.server.v1_12_R1.PlayerConnection.a(PlayerConnection.java:989)
    18.02 10:45:01 [Server] WARN at net.minecraft.server.v1_12_R1.PacketPlayInBlockPlace.a(PacketPlayInBlockPlace.java:26)
    18.02 10:45:01 [Server] WARN at net.minecraft.server.v1_12_R1.PacketPlayInBlockPlace.a(PacketPlayInBlockPlace.java:1)
    18.02 10:45:01 [Server] WARN at net.minecraft.server.v1_12_R1.PlayerConnectionUtils$1.run(SourceFile:13)
    18.02 10:45:01 [Server] WARN at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    18.02 10:45:01 [Server] WARN at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    18.02 10:45:01 [Server] WARN at net.minecraft.server.v1_12_R1.SystemUtils.a(SourceFile:46)
    18.02 10:45:01 [Server] WARN at net.minecraft.server.v1_12_R1.MinecraftServer.D(MinecraftServer.java:748)
    18.02 10:45:01 [Server] WARN at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:406)
    18.02 10:45:01 [Server] WARN at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:679)
    18.02 10:45:01 [Server] WARN at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:577)
    18.02 10:45:01 [Server] WARN at java.lang.Thread.run(Thread.java:748)
     
  16. I just released an update to PCAPI (the util that is throwing the error). Reload your server to let it auto-update. Does the problem still occur on the newer version?

    If so, what server architecture are you using (Bukkit,Spigot,PaperSpigot)
     
  17. Restarted server twice. Still happening.

    Code (Text):
    This server is running CraftBukkit version git-Spigot-4bd94dc-f4ca180 (MC: 1.12.2) (Implementing API version 1.12.2-R0.1-SNAPSHOT)
    18.02 19:32:57 [Server] INFO Checking version, please wait...
    18.02 19:32:57 [Server] INFO You are 3 version(s) behind
    18.02 19:33:03 [Server] INFO QualityArmory version 1.1.48
    18.02 19:33:03 [Server] INFO Author: Zombie_Striker
    18.02 19:33:41 [Server] INFO PluginConstructorAPI version 1.0.13
    18.02 19:33:41 [Server] INFO Author: Zombie_Striker
     
  18. Searched around and found pcapi 1.0.19 and installed it manually. Seems to have fixed the npe issue. Don't know why pcapi won't update itself though. Guess I'll just have to manually update it when I remember to.
     
  19. Is it possible to repair the weapons?
     
  20. Hi can i make a fork ( personal use only )
    That work for 1.8.8 spigot?
    ( personal use only ) ?
     

Share This Page