Spigot QuickShop Reremake - 1.18 Ready - Multi Currency

A shop plugin that allows players to easily sell/buy any items from a chest without any commands.

  1. Ghost_chu submitted a new resource:

    QuickShop Reremake ★ A great chest shop plugin - A shop plugin that allows players to sell items from a chest with no commands. Now support 1.13 with

    Read more about this resource...
    • Funny Funny x 1
  2. Hello, every time a user buys something in my shop or in an administrator shop I get a purchase message. Any way to deactivate those messages or to implement that option?
  3. Ghost_chu updated QuickShop Reremake ★ A great chest shop plugin with a new update entry:

    A cool update for controlpanel and with many bug fix.

    Read the rest of this update entry...
  4. Update to 1.3.1 and you can close it in config.yml
    • Like Like x 1
  5. Is it possible to add Minetinkers Modifiers so we can trade them from chest please?
  6. Listen on need many works, please submit it on Github issues tracker :D
  7. I updated the plugin, I did it with the folder in clean.
    I get the following message when a user wants to buy in my ADMIN shop.

    Note: When buying in the shop "User" the error does not appear and the purchase is done without problems.

    Note2: I did not move anything in the configurationt

    Code (YAML):
    22.11 22:43:09 [Server] WARN [QuickShop] Task #3271 for QuickShop vReremake 1.3.1 generated an exception
    22.11 22:43:09 [Server] INFO java.lang.NumberFormatException
    : For input string: "Unlimited"
    22.11 22:43:09 [Server] INFO at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65) ~[?:1.8.0_161]
    22.11 22:43:09 [Server] INFO at java.lang.Integer.parseInt(Integer.java:580) ~[?:1.8.0_161]
    22.11 22:43:09 [Server] INFO at java.lang.Integer.valueOf(Integer.java:766) ~[?:1.8.0_161]
    22.11 22:43:09 [Server] INFO at org.maxgamer.quickshop.Shop.ShopManager.actionBuy(ShopManager.java:367) ~[?:?]
    22.11 22:43:09 [Server] INFO at org.maxgamer.quickshop.Shop.ShopManager.access$100(ShopManager.java:34) ~[?:?]
    22.11 22:43:09 [Server] INFO at org.maxgamer.quickshop.Shop.ShopManager$1.run(ShopManager.java:332) ~[?:?]
    22.11 22:43:09 [Server] INFO at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftTask.run(CraftTask.java:63) ~[CorpMore.jar:git-Paper-386] 22.11 22:43:09 [Server] INFO at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:423) ~[CorpMore.jar:git-Paper-386]
    22.11 22:43:09 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:1008) ~[CorpMore.jar:git-Paper-386]
    22.11 22:43:09 [Server] INFO at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:439) ~[CorpMore.jar:git-Paper-386] 22.11 22:43:09 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:943) ~[CorpMore.jar:git-Paper-386]
    22.11 22:43:09 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:841) ~[CorpMore.jar:git-Paper-386]
    22.11 22:43:09 [Server] INFO at java.lang.Thread.run(Thread.java:748) [?:1.8.0_161]

    Problem solved in version

    Thanks to the developer for correcting it quickly. :D :D
    #10 cPathz, Nov 23, 2018
    Last edited: Nov 23, 2018
  8. Fixed, and posting resource update.
    • Like Like x 1
    • Useful Useful x 1
  9. Minor issue:
    • Sneak to control not work, the other two options work fine.
  10. Thanks report it, i will check it and fix in next version. :D
    • Like Like x 1
    • Like Like x 1
  11. Fixed in
    • Friendly Friendly x 1
  12. Love, love love the plugin. One issue I'm having though unfortunately is.


    Whenever someone clicks on the [set] button next to price it bring up the sign to 'edit sign message' and gives an internal error. The message in the console is in the pastebin.

    Any idea what's going on or how I can prevent this?

    Edit - author fixed the issue =)
    #17 Xorgrin, Nov 24, 2018
    Last edited: Nov 30, 2018
  13. This error appears in any of these versions. or

    If you are a user or administrator, if you put a SIGN (anywhere) with the first line with text the following error appears:
    Code (YAML):
    24.11 20:32:46 [Server] WARN [QuickShop] Task #3452 for QuickShop vReremake generated an exception
    24.11 20:32:46 [Server] INFO java.lang.NullPointerException
    : null
    24.11 20:32:46 [Server] INFO at org.maxgamer.quickshop.Command.QS.signGUIApi(QS.java:55) ~[?:?]
    24.11 20:32:46 [Server] INFO at org.maxgamer.quickshop.QuickShop$1$1.run(QuickShop.java:189) ~[?:?]
    24.11 20:32:46 [Server] INFO at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftTask.run(CraftTask.java:63) ~[CorpMore.jar:git-Paper-386]
    24.11 20:32:46 [Server] INFO at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:423) ~[CorpMore.jar:git-Paper-386]
    24.11 20:32:46 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:1008) ~[CorpMore.jar:git-Paper-386]
    24.11 20:32:46 [Server] INFO at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:439) ~[CorpMore.jar:git-Paper-386]
    24.11 20:32:46 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:943) ~[CorpMore.jar:git-Paper-386]
    24.11 20:32:46 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:841) ~[CorpMore.jar:git-Paper-386]
    24.11 20:32:46 [Server] INFO at java.lang.Thread.run(Thread.java:748) [?:1.8.0_161]

    24.11 20:35:39 [Server] WARN [QuickShop] Task #5004 for QuickShop vReremake generated an exception 24.11 20:35:39 [Server] INFO java.lang.NullPointerException: null 24.11 20:35:39 [Server] INFO at org.maxgamer.quickshop.Command.QS.signGUIApi(QS.java:55) ~[?:?]
    24.11 20:35:39 [Server] INFO at org.maxgamer.quickshop.QuickShop$1$1.run(QuickShop.java:189) ~[?:?]
    24.11 20:35:39 [Server] INFO at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftTask.run(CraftTask.java:63) ~[CorpMore.jar:git-Paper-386]
    24.11 20:35:39 [Server] INFO at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:423) ~[CorpMore.jar:git-Paper-386]
    24.11 20:35:39 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:1008) ~[CorpMore.jar:git-Paper-386]
    24.11 20:35:39 [Server] INFO at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:439) ~[CorpMore.jar:git-Paper-386]
    24.11 20:35:39 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:943) ~[CorpMore.jar:git-Paper-386]
    24.11 20:35:39 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:841) ~[CorpMore.jar:git-Paper-386]
    24.11 20:35:39 [Server] INFO at java.lang.Thread.run(Thread.java:748) [?:1.8.0_161]

    This does not happen if you put text in the 2nd, 3rd or 4th position. It only happens when you put text in the first line.

    ----- ------- ----- ------- ----- ------- ----- ------- ----- ------- ----- -------

    I deleted the files and they were generated again (except the DB)
    Now the error does not appear in the console. But writing something on the first line of the sign is like modifying a store.

    My server is running Paper version git-Paper-386 (MC: 1.13.1) (Implementing API version 1.13.1-R0.1-SNAPSHOT)
    #18 cPathz, Nov 25, 2018
    Last edited: Nov 25, 2018
  14. • On my server the "Sneak to control" option still doesn't work.

    • If it works for you it is likely that my version of PaperSpigot 1.13.1 is failing or not compatible.

    Thanks in advance for your work.

    My server is running Paper version git-Paper-386 (MC: 1.13.1) (Implementing API version 1.13.1-R0.1-SNAPSHOT)
  15. I will check it, maybe in somewhere it not ve fixed.
    • Agree Agree x 2