Bukkit Rainbow Armour 1.7.1

The #1 Rainbow Armour Plugin!

  1. This is a good idea, it will be added to the next release!
     
  2. If you have any suggestions for the 1.6 release now is the time to speak up. Leave a comment telling me what you want and what you want it to do!
     
  3. See my suggestion on the previous page :)
     
  4. This has been implemented into 1.6! There are still a few things I have to do before the plugin is ready as I have been busy IRL. But it should be out soon. Thank you for the suggestion!
     
  5. xtechgamer735 updated Rainbow Armour with a new update entry:

    v1.6.0

    Read the rest of this update entry...
     
  6. "onlyApplyExistingArmour"
    does this make any leather armor turn into rainbow armor when worn?
    and is there a command i can let players use to change there pattern? or how does the pattern setting work

    sorry, i haven't got around to test this plugin just yet
     
  7. Yes, this means that the players must be wearing the armour. Currently the pattern applies to all items or rainbow armour and must be changed in the config.
     
    • Friendly Friendly x 1
  8. This could be another plugin, but for some reason the armor is getting duplicated to my first slot http://prntscr.com/7gj9rs
     
  9. Theepwner

    Supporter

    You use itemfix?
     
  10. Wish I would of read this post before I figured it out. Yep, thanks.
     
  11. Theepwner

    Supporter

    In an update it says you added support for /rainbowarmor and such, the U.S. version. The command /ra armor, or /rainbowarmor armor won't work. Though the command /rainbowarmor armour will. I believe the issue only exists with this certain command.

    Also, the messages.yml seems to not be completely functional.
    http://hastebin.com/tuxuyofiya.avrasm
    For commandNotFound, it is still doing "Error. Use &b/rainbowarmour help" in-game. (tested with /ra reload, and server restart)

    I also wish for you to allow /ra help output to be customizable, since it can only show "/rainbow armour X", and my server has a much larger U.S. playerbase.

    Lastly, when using /ra reload this appears in console:
    Code (Text):

    [01:09:58] [Server thread/INFO]: Theepwner issued server command: /ra reload
    [01:09:58] [Server thread/INFO]: [RainbowArmour] Disabling RainbowArmour v1.6.2
    [01:09:58] [Server thread/INFO]: [RainbowArmour] Enabling RainbowArmour v1.6.2
    [01:09:58] [Server thread/WARN]: [RainbowArmour] Could not save messages.yml to plugins/RainbowArmour/messages.yml because messages.yml already exists.
    [01:09:58] [Server thread/INFO]: [RainbowArmour] Enabled
     
    Thanks, glad to have switched from that old discoarmor plugin on bukkit.
     

  12. Firstly, thank you for letting me know about these, I endeavour to fix them in the next release. I am glad you like the plugin!

    1 (/rainbowarmor armour) - This will be fixed in the next release, thank you for letting me know!

    2 (messages.yml) - I have tested this on my end and cannot seem to reproduce the issue. Please provide me with your messages.yml and the command you used which caused this issue.

    3 (Help Output) - Making this customisable might be slightly overkill, but I can make it so a config option toggles it to US mode?

    4 (Console Log) - This is intentional, I makes a new messages.yml at reload if the file is not there incase someone deletes it and wonders why nothing is working. Unfortunately I cannot suppress this message.


    Again, thank you for reporting and please let me know of any future issues/requests!
     
  13. Theepwner

    Supporter

    2 - I provided the messages.yml, and the command I used is simply /ra reload. The issue is that I changed the commandNotFound message to the U.S. version of armor, yet it still is outputting the old message. http://hastebin.com/tuxuyofiya.avrasm

    3 - A config option to U.S. mode would be fine. But I was also thinking of changing it to show /ra instead of /rainbowarmor. Maybe include it to say /ra is an alias or something?

    4 - Maybe modify the console notifications on reload to be:
    Code (Text):

    [01:09:58] [Server thread/INFO]: Theepwner issued server command: /ra reload
    [01:09:58] [Server thread/INFO]: [RainbowArmour] Reloaded RainbowArmour v1.6.2
     
    And only include info about messages.yml if that file isn't found? The current output confused me and made me think that reloading the plugin doesn't save the changes to messages.yml.

    Edit: Also, how would I make armor transition faster than 1? Could I use decimals like 0.5?
     
    #55 Theepwner, Jul 11, 2015
    Last edited: Jul 11, 2015
  14. 2 - This is very strange, I have tried your messages file on my end and it works perfectly. Do the other messages change when you edit them?

    3 - This can be done no problem!

    4 - Ive changed how the file is saved slightly and a message is now only outputted if the file is missing and has to be re created. Thanks for pointing this out as I can see it could cause confusion. I cannot remove the Disabling RainbowArmour message as this is done by Spigot.

    5 - Yes you can use decimals etc... and go as low as you need.
     
  15. Theepwner

    Supporter

    Yes, the other messages change when I edit them. I'm using spigot version: git-Spigot-f928e7a-f27339c (MC: 1.8.7).

    Also, I've noticed that armor seems to change faster when looking at a player doing it, compared to looking at yourself through your inventory.
    Yes, other messages are properly changed after editing and reloading. I really have no clue what's happening.

    Also, how does my chestplate go out of sync from my other armor after doing /ra armour?
    [​IMG]

    Lastly, I've noticed sometimes how armor seems to update quicker when looking at someone, compared to looking at yourself through your inventory/third person view. This is notable when using 0.5 as the speed. Any ideas?
     
  16. I have tested this with multiple versions of the plugin on different versions of spigot (incl. 1.8.7) and everything works fine for me. Perhaps try re downloading the plugin incase it has been damaged in some way as I also cannot re produce the armour issue.

    The update issue is interesting, as it is something I have also experienced and I am convinced its something to do with Bukkit rather than the plugin its self as it is something I have tried to fix in the past..

    This has been brought to my attention before - and no it is not.
     
  17. Theepwner

    Supporter

    So for the messaging bug:
    I've deleted my messages.yml, /ra reload to regen it, and edited only commandNotFound to this:

    commandNotFound: "&3Error. Use &b/rainbowarmor help"

    Then simply saved the file, and /ra reload. Yet in chat it still shows "Use /rainbowarmour help". Would this issue be happening because of using /ra reload?
     
  18. This command does reload the messages file along with the plugin its self and should not be the issue as that is how I have been testing at my end. Out of curiosity have you tried changing it to something completely different e.g. "&cNo Command" then restarting the server? This is a very strange issue.