Bukkit Rainbow Armour 1.7.1

The #1 Rainbow Armour Plugin!

  1. Intriguing - I will have a look into it. Has the plugin given you any other errors? Maybe on startup or whist enabling anything?
     
  2. I don't believe so, this is the first time I've noticed anything like this. But I'll also keep my eye out
     
  3. Fantastic thanks! Ill let you know if I find anything.
     
  4. I haven't noticed any other plugin conflicts/errors
    But the exception message definitely started spiking in my console,
    it is also adding to lag as well
    http://hastebin.com/wukihanedu.vbs
     
  5. This is a very strange issue, I have been testing this on my local test server and another server and I cannot seem to replicate this issue. What version of Bukkit/Spigot are you using?
     
  6. Theepwner

    Supporter

    We were getting very spammy errors in console as well after updating.

    Fixed it by updating the config.
     
  7. I'll try that now!
    In case it doesn't work and for future reference my Spigot version is:
    spigot-BT45_1.8.8_10.21.jar
    Also here is the updated config: http://hastebin.com/yekajedevi.sm
     
  8. Let me know if this works. I am sorry for any inconvenience and I will continue to find the cause of this problem.
     
  9. Theepwner

    Supporter

    Yeah, there's issues with this version. My creative server is crashing quite frequently due to this I believe. Not sure what is causing the mad errors and such, but once the errors start going, it will inevitably lead to a crash.
     
  10. This is a strange issue. I cannot seem to re produce it, but it looks like something somewhere is null that shouldn't be. It is unfortunate the error messages are not more detailed. Keep me posted with what is happening, does re generating the config not provide a fix?

    Edit: Could you provide me with some of the log information so I can take a closer look?
     
    #90 xtechgamer735, Nov 4, 2015
    Last edited: Nov 4, 2015
  11. Theepwner

    Supporter

    Okay so I took a look at my crash logs, and it appears that the errors start after a player disconnect.
    First error is this, and spams for a long time:
    http://hastebin.com/azeciseyaf.avrasm
    Second error after some time:
    http://hastebin.com/wajexequle.avrasm
     
  12. Thank you for this information, the first paste is very helpful as it gives me a location off the error - but unfortunately the second only confirms a task causing it (helpfully the same task, as we can tell from comparing both of the logs). Does the error only start to occur once someone has logged out, and did they have armour enabled?

    I will hopefully release an update soon as the error will be easy to fix once I have found it. Please let me know if you have any more information!
     
  13. Thank you - hopefully I will be releasing a fix this weekend!
     
  14. Theepwner

    Supporter

    • Optimistic Optimistic x 1
  15. I have nearly tried everything and haven't found the bug yet, as what I was expecting it to be it isn't. I don't see much point releasing an update for the sake of it either if the problem has not been fixed.
     

Share This Page