Spigot Random Spawn 1.3.1

Teleport someone to a random spawn point in the world.

  1. When will this be updated for 1.11.2?

    I've tried it and it loads without any errors, except it will not random tp you on first join or if you don't have a bed spawn set.
     
    #2 Lutandar, Jan 3, 2017
    Last edited: Jan 3, 2017
  2. Okay, so let me get this straight...

    When users first join the server (as in they've never never joined the server before), they don't get teleported? Are you sure that "on-first-join" is set to true?

    And what do you mean with "don't have a bed spawn set"?

    If you're having any issues I would encourage you to change debug to true and make sure all the listeners you want are being registered properly.
     
  3. Hello, nice plugin, but... add to the wiki how to create a sign, usually is [randomspawn] but you set just randomspawn and can create confusion.
    Nice plugin!
     
    #6 Masta, Jan 20, 2017
    Last edited: Jan 20, 2017
  4. I'll look in the code to see if there's any confusion and update the readme and post accordingly. Thanks for the suggestion. :L
     
  5. When can we see a update/bug fix for when it respawns you in the nether on death leaving you stranded there?! Thanks!
     
  6. Hey sorry, I've been very bad about responding to people. I've had some personal family issues along with huge server migrations. We have a livestream on Saturday, so I'll be able to work on it later after that. Spring break is next week for me too so there's that.
     
  7. @Lutandar just set the fallback world, and blacklist world_nether and such, you should be good to go then! Make sure to rename your config.yml so the new one can be generated! I don't feel like it's worth the time to write a migration method as it's a pretty small configuration file.
     
  8. I've updated to 1.3.0 and delete the old config so the new one would generate, now I have this error?
    http://pastebin.com/TkQXpmtW

    How I setup the new config,
    http://pastebin.com/euUHSswg

    + Might I add, upon respawning users will respawn in water/lava.
    Could this be changed to prevent this or have a block-blacklist as well?
     
  9. Just fixed that! My bad! I misspelled something. Just posted an update. Also, in your config...you're missing "sign-trigger", don't remove that even if the signs are disabled haha. Might want remove the configuration file and reload the plugin. Sorry again!

    The lava thing should not be happening. It should change the block under them to stone. If this does not, please let me know. However, if they're spawned in an area with water/lava, that's expected. But it should not kill them unless they move off the stone block.
     
  10. @MatthewSH Just a feature suggestion once it teleports you to the randomspawn it will also set the spawnpoint individually for you there this way if you die you spawn at that spawnpoint
     
  11. Hi Mattew i've a problem with RandomSpawn plugin.

    When my players try to execute /randomspawn, server reply: "You don't have the correct permission to perform this action".. with or without permissions randomspawn.command set on PermissionEx.

    Can you help me?
     
  12. Will you ever update the plugin? If not do you know of anything similar?