Spigot Random Teleport (full nether support!) 2.0.0

Teleport players to a random safe location. Supports exclusion of protection plugins

  1. DarkEyeDragon submitted a new resource:

    Random Teleport - Teleport player to a random safe location, with worldguard and faction support

    Read more about this resource...
     
  2. NOTE: Java 11 or higher is required as I'm using time formatting utilities only availible from Java 11 and higher. It's about time you start updating anyway.

    Just so you know its the hosts that wont update to Java11, most server admins have no control over it.
     
  3. Yeah I know. But i'm not going to revert to J8 and spend more time on formatting time when i have handy util classes to do it for me.
    If a host was using J8 at this point i'd probably just switch host. But maybe i'm just picky. The plugin will still work. Just the cooldown formatting will be messed up.

    Edit: How the tables turned lol. J8 is now fully supported
     
    #3 DarkEyeDragon, Mar 18, 2020
    Last edited: Apr 15, 2020
  4. DarkEyeDragon updated Random Teleport with a new update entry:

    Updated to 1.1

    Read the rest of this update entry...
     
  5. This plugin is absolutely fantastic! Working great and as expected. One thing I'd love to see, would be an option to change the message for "Locations queue depleted" in the config. Minor detail, but I like syncing all my messages! Keep up the great work =) upload_2020-4-14_17-23-37.png
     
  6. That can surely be done. Thanks for the kind words.
     
  7. DarkEyeDragon updated Random Teleport with a new update entry:

    Update to version 1.2.0 (important bugfixes!)

    Read the rest of this update entry...
     
  8. DarkEyeDragon updated Random Teleport with a new update entry:

    1.3.0 - Added delayed teleport

    Read the rest of this update entry...
     
    #9 DarkEyeDragon, Apr 20, 2020
    Last edited: Apr 22, 2020
  9. How do we add world based radius and offsets? The config looks exactly the same and I did a fresh install.
     
  10. Specific worlds will be planned for the next release (Working on that now). I'll make it more clear in the post :p
     
  11. DarkEyeDragon updated Random Teleport with a new update entry:

    More commands, better performance and overal cleanup

    Read the rest of this update entry...
     
  12. Hi. I tested your plugin on a test server and it was working fine. But on my production server it doesn't work and i have this error. Thanks


    Code (Text):
    [09:30:08] [Server thread/ERROR]: Error occurred while enabling RandomTeleport v1.4.0 (Is it up to date?)
    java.lang.NullPointerException: null
        at me.darkeyedragon.randomtp.location.LocationFactory.getWorldConfigSection(LocationFactory.java:24) ~[?:?]
        at me.darkeyedragon.randomtp.RandomTeleport.populateWorldQueue(RandomTeleport.java:113) ~[?:?]
        at me.darkeyedragon.randomtp.RandomTeleport.onEnable(RandomTeleport.java:97) ~[?:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[patched_1.15.2.jar:git-Paper-334]
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:380) ~[patched_1.15.2.jar:git-Paper-334]
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:483) ~[patched_1.15.2.jar:git-Paper-334]
        at org.bukkit.craftbukkit.v1_15_R1.CraftServer.enablePlugin(CraftServer.java:472) ~[patched_1.15.2.jar:git-Paper-334]
        at org.bukkit.craftbukkit.v1_15_R1.CraftServer.enablePlugins(CraftServer.java:386) ~[patched_1.15.2.jar:git-Paper-334]
        at net.minecraft.server.v1_15_R1.MinecraftServer.a(MinecraftServer.java:488) ~[patched_1.15.2.jar:git-Paper-334]
        at net.minecraft.server.v1_15_R1.DedicatedServer.init(DedicatedServer.java:298) ~[patched_1.15.2.jar:git-Paper-334]
        at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:900) ~[patched_1.15.2.jar:git-Paper-334]
        at java.lang.Thread.run(Thread.java:834) [?:?]
     
  13. It looks like you have a flaw in your config somewhere. Could you check your config? Or let it regenerate to see if still happens. If it still occurs post your config so i can help identify the problem and fix it.

    Edit: It might break if you have worlds in the list that do not exist.
     
  14. That was the problem... i didn't realised that this part was configurable. I change the name of the world to match my world and it works now. Thantk you.

    *EDIT* I can't find how to setup permissions to let players rtp to a specific world from every other worlds. I want them to rtp to my world zc_world from the spawn for example.
     
    #15 mvez73, Jun 5, 2020
    Last edited: Jun 5, 2020
  15. Glad to hear its solved! I've started writing the wiki explaining how to set it up. Feel free to give me feedback on it if something isn't clear.
    https://github.com/DarkEyeDragon/RandomTeleport/wiki/Setting-up

    In short: You need to give them `rtp.teleport.world` to allow them to rtp to different worlds (they're not currently in). If you want to make it so only certain people can do so, you set `needs_world_permission` to true for that world and give the players `rtp.world.zc_world` for example. However this last part is optional
     
  16. That's exactly what i did. Plus rtp.teleport.self and thes can't rtp if they are not in zc_world. If they try to rtp in another world they have a message telling them they can't in this world. That's ok. But if they try to rtp in zc_world from the spawn they have a message telling they don't have permission to do that.

    I will double check in a few minutes. Thanks.
     
  17. Can you show me the config?
     
  18. Here's my config:

    Code (YAML):
    message:
      initteleport
    : '&aSearching for safe location to teleport to...'
      initteleport_delay
    : '&aYou will be teleported in &6%s seconds. &aDo not move!'
      teleport_canceled
    : '&aYou moved! Teleportation canceled'
      teleport
    : '&bA safe place has been found! Teleporting...'
      depleted_queue
    : '&6Locations queue depleted... Forcing generation of a new location'
      countdown
    : '&cYou cannot teleport for another &6%mp minutes %sp seconds'
      no_world_permission
    : '&cI am sorry, you cannot rtp in %world'
      empty_queue
    : '&cThere are no locations available for this world! Try again in a
        bit or ask an admin to reload the config.'
      economy
    :
        insufficient_funds
    : '&cYou do not have enough money to rtp!'
        payment
    : '&aYou just paid &b%price &ato rtp!'
    queue
    :
      size
    : 5
      init_delay
    : 60
    worlds
    :
      zc_world
    :
        use_worldborder
    : true
        needs_world_permission
    : true
        radius
    : 50000
        offsetX
    : 0
        offsetZ
    : 0
    teleport
    :
      cooldown
    : 60m
      delay
    : 0s
      cancel_on_move
    : true
    plugins
    :
    - WorldGuard
    - GriefPrevention
    debug
    :
      show_queue_population
    : true
    economy
    :
      price
    : 0
    and my permissions:

    Code (Text):
    rtp.teleport.self true never none
    rtp.teleport.world true never none
    rtp.world.zc_world true never none
    *EDIT* what is the exact command to rtp in another world? /rtp world zc_world? /rtp zc_world? /rtp PlayerName zc_world?
     
    #19 mvez73, Jun 6, 2020
    Last edited: Jun 6, 2020

  19. hmm that looks all fine. And the right command would be /rtp zc_world and /rtp player world would be valid too
    I'll do some testing to see if theres something wrong with how this is handeled.