RandomSK v2.7.1 (Is it up to date?)

Discussion in 'Spigot Plugin Help' started by Fargus, May 24, 2017.

  1. Dear

    I have this error in my console:

    Someone knows where I could find an update?

    Code (Text):
    [04:00:37] [Server thread/INFO]: [RandomSK] Enabling RandomSK v2.7.1
    [04:00:37] [Server thread/ERROR]: Error occurred while enabling RandomSK v2.7.1 (Is it up to date?)
    java.lang.NoSuchMethodError: org.bukkit.Server.getOnlinePlayers()[Lorg/bukkit/entity/Player;
        at com.mirre.random.utils.comphenix.TinyProtocol.registerPlayers(TinyProtocol.java:235) ~[?:?]
        at com.mirre.random.utils.comphenix.TinyProtocol.<init>(TinyProtocol.java:101) ~[?:?]
        at com.mirre.random.RandomSK$1.<init>(RandomSK.java:116) ~[?:?]
        at com.mirre.random.RandomSK.onEnable(RandomSK.java:116) ~[?:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:271) ~[spigot.jar:git-Spigot-3fb9445-6e3cec8]
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [spigot.jar:git-Spigot-3fb9445-6e3cec8]
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot.jar:git-Spigot-3fb9445-6e3cec8]
        at org.bukkit.craftbukkit.v1_11_R1.CraftServer.enablePlugin(CraftServer.java:376) [spigot.jar:git-Spigot-3fb9445-6e3cec8]
        at org.bukkit.craftbukkit.v1_11_R1.CraftServer.enablePlugins(CraftServer.java:326) [spigot.jar:git-Spigot-3fb9445-6e3cec8]
        at net.minecraft.server.v1_11_R1.MinecraftServer.t(MinecraftServer.java:421) [spigot.jar:git-Spigot-3fb9445-6e3cec8]
        at net.minecraft.server.v1_11_R1.MinecraftServer.l(MinecraftServer.java:382) [spigot.jar:git-Spigot-3fb9445-6e3cec8]
        at net.minecraft.server.v1_11_R1.MinecraftServer.a(MinecraftServer.java:337) [spigot.jar:git-Spigot-3fb9445-6e3cec8]
        at net.minecraft.server.v1_11_R1.DedicatedServer.init(DedicatedServer.java:272) [spigot.jar:git-Spigot-3fb9445-6e3cec8]
        at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:544) [spigot.jar:git-Spigot-3fb9445-6e3cec8]
        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_111]
     
  2. This is their download site: http://skmirror.duetro.pw/path.php?p=addons/RandomSK

    Seems like 2.7.1 is the latest version. Maybe you can try with 2.7?
    If that still does not work, I suggest that you contact the developer.

    If you find a version that works, do not forget to change 'soft api exceptions: false' to 'soft api exceptions: true' in the Skript config, if you use this plugin with version 1.9 or higher!
     
  3. Thanks a lot
     
    • Friendly Friendly x 1