Solved Really strange WorldEdit terraforming glitch?

Discussion in 'Spigot Plugin Help' started by SecretAgentMango, Jun 23, 2016.

  1. So on my server I have MultiVerse, and one of my worlds is a flatworld. I want to try and make a mountain on this world, so I made my stone pick a brush that create sand spheres. However, when I place a sand sphere, it just melts right through the grass and goes into the "infinite void" that's beneath the bedrock on the flatworld. When I do this on any other "world," however, it works just fine. Why is this happening? Is my plugin corrupted or something?
     
  2. It's not a glitch, it's all right.

    Seems like you just don't understand how to use WorldEdit.
    I guess your flatworld is default (vertically 1 bedrock, 2 dirt, 1 grass, 252 air)?
    That's what is happening when you use a sphere sand brush (radius > 2):
    • WE replaces all blocks within your defined radius by sand
    • So it also replaces the bedrock
    • Sand falls down into the void because there is no more solid block underneath it
    How to solve this:
    • Use a WE mask, so your brush replaces air only
    • OR alternatively: modify the flat world generator settings, so it generates more solid blocks (like 1 bedrock, 59 stone, 3 dirt, 1 grass, 192 air)
    Good luck
     
    • Like Like x 2
  3. The mask worked fine. Thanks!
     
  4. I have the same problem with sand going down to bedrock, but this is in a normal Minecraft world and not a flatworld. Every other material works fine, it's just sand that doesn't The solutions someone posted doesn't work for me so I have no idea what to do.