Region file gets corrupted when added to the server

Discussion in 'Spigot Help' started by Folf, Feb 16, 2020.

  1. So, in order to reduce my world size, I decided to delete all region files that weren't modified since a date, I thought that would be no problem and that Minecraft would simply regenerate those regions when necessary, however, as soon as I started the server errors such as `Chunk [53, 366] is allocated, but stream is missing`, and `Chunk [-374, -224] header is truncated: expected 8192 but read 0` started showing up, I checked where these chunks were and since they where on the deleted regions and I couldn't find any issue with the map, I decided to ignore it.

    The problem started when a specific region file (6.-1) got corrupted, I have a map backup on my computer and loading it in single player works just fine, however, as soon as I upload this region file to the server and start it, the chunks on that region seem to get shuffled, and I get a few of these error messages:
    ```
    [13:38:30 ERROR]: Chunk file at [192, -19] is in the wrong location; relocating. (Expected [192, -19], got [194, -17])
    [13:38:30 ERROR]: Chunk file at [193, -19] is in the wrong location; relocating. (Expected [193, -19], got [214, -9])
    ```
    I tried running Minecraft Region Fixer on the world backup and no problems where found, I also have no clue about what could be causing this issue since the map backup works just fine (even without the deleted regions), could anyone help me with this?


    Edit1: I tried deleting the region file to see what would happen, it resets and then works just fine, then I uploaded the backed up region file and it resulted in the same problems

    Edit2: Log once I load the affected region:
    https://pastebin.com/raw/ugmhWrUn

    Edit3: Seems like this is a problem with minecraft itself https://bugs.mojang.com/browse/MC-161823
     
    #1 Folf, Feb 16, 2020
    Last edited: Feb 16, 2020