Suggestion Remove version tags of unsupported/outdated versions

Discussion in 'Community Feedback and Suggestions' started by Escad, Jan 11, 2020.

  1. So version tags were added for the Spigot Plugin Development subforum. That's great and viewers will know better how to respond with less initial questions, but it seems unnecessary and even to the point of cluttered to add tags for old versions. By old versions, I'm referring to basically all major versions pre 1.12 (as even 1.11 is already 3 and a half years old), but primarily 1.9-1.7, which at the youngest is still nearly 4 years old.

    Furthermore (although perhaps less likely to be received well), I believe that locking threads based on these old versions would help encourage server owners that are behind to move forward. While there may be some desirable client-side mechanics in them, there are no technical reasons server-side to not update.
     
    • Funny Funny x 2
    • Like Like x 1
    • Optimistic Optimistic x 1
  2. Choco

    Moderator

    Now here's my concern. One, I believe you're absolutely right. There's no reason for threads requesting support outside of the versions supported by Spigot to be permitted on the forums. If it were up to me, I would take the Forge forums approach and outright lock any thread asking for assistance with another version. Secondly, the addition of these version tags further legitimizes that these versions are still supported which doesn't seem to match with what's been announced upon new releases of Spigot.

    On the other hand, these prefixes help categorize threads and let myself (or many other developers) know to outright ignore those threads and not offer any support. I understand the addition of the prefixes and it makes sense to add them back to these versions, I'm just unsure as to the protocol at this point. Are we supporting these versions or not?
     
    • Like Like x 2
    • Agree Agree x 1
  3. That's true. I wouldn't bet on there being a way to enforce the usage of tags either (even so, who says someone won't still post 1.8 questions on a 1.12/1.13 tagged thread). I'd say it's just a matter of the version being known, reports from the community, and manual moderation.
     
  4. I understand where you're coming from, because these versions are no longer supported. However, I know that many people still use certain versions, such as 1.8, for PVP mechanics. I think that the use of older versions for certain mechanics is a legitimate reason to operate a server on a version such as 1.8. With so many people still using these versions, I do think they have a good reason to be able to post to the forums asking for support just like anyone else can. :p
     
    • Optimistic Optimistic x 2
  5. Choco

    Moderator

    Those people should be full-well capable of supporting themselves. As far as Spigot is concerned, 1.15 (and 1.14 last I recall) are the only supported versions on the platform. The reasoning is entirely irrelevant. All that matters is what the platform supports and that is the latest version. If you want to run 1.8, power to you. Do not, however, expect any support whatsoever from the platform. In the IRC, we would outright kick you ;P
     
    • Agree Agree x 3
    • Funny Funny x 2
  6. 1.8 is a 5 year old version. Threads on it have still been made up to this point. There are plenty of existing threads to answer their questions, and those with the jar have a local copy of the javadocs for their own use. If that's still not enough, they can ask questions once they've updated. A majority of the developers here know more about recent versions rather than older ones anyways, which already limits the help they might receive.
     
    • Like Like x 2
  7. md_5

    Administrator Developer

    The problem is people will ask anyway and if necessary just use the wrong prefix.

    Unless we ban creating and responding to such threads just deleting the version would probably make things worse.
     
    • Agree Agree x 4
  8. See here
    This is essentially what I'm suggesting.
     
  9. A custom profile field to show legacy crap and have it off by default, perhaps an option?

    [-] Show legacy versions.
    (resets every time a new spigot version comes out, 1.15.2 / 1.16.0)

    And have it opt-in. Those who really wanna stick to 1.7 and 1.8 stuff or even 1.12, they can go to their profile, toggle it back on, and then perhaps get that content again.
     
  10. Yeah, you guys are actually pretty right on this :p
    The developers of these versions should be knowing what they are doing with them because it is pretty outdated.
    I was just thinking about how common it is for people to still use 1.8 and the effects that has on the forums as well.
     
    • Friendly Friendly x 1
  11. Just don't use the pre-fix option

    Just put in your title as you would have done before - it is a choice

    The Tag is there, so that you have the option to aim your enquiry to the correct audience.

    This is relevent as many server owners are reluctant to update to the 'bleeding edge' server version.

    And fancy getting a relevent answer for a 1.13.2 server, when you need it for a 1.15.1 server?
    (You would scowl)


    The answer could be totaly correct, abiet for the wrong version support!

    This is not about pre-1.12 support, and next year? (Oh, lol that is history too, as will 1.15.1) :ROFLMAO:


    Have you guys nothing better to do than argue over semantics?

    The Tags are there to assist the viewer to decide whether they wish to contribute to a post, or not.
     
    #11 Goldentoenail, Jan 11, 2020
    Last edited: Jan 11, 2020
    • Agree Agree x 2
  12. At the end of the day, see a thread prefixed with 1.8.x? Just don't respond if you don't want to.
    No one is forcing you to respond.

    If someone so chooses to use 1.7.x or 1.8.x and requests help, we shouldn't stop them from getting help.
    Its up to you to decide whether or not you want to offer the help.


    Personally I don't help anyone on much stuff for 1.12.2 or lower for 2 reasons:
    1) I started java development in 1.13, so I actually don't know all the old stuff relating to blocks, items, numerical IDs, etc
    2) Over the years so much has been added to the API. Since I started with 1.13, the stuff I need is in the API. Quite often I see these threads "How I do X?" <-- when X is available in the 1.13+ API and not in 1.8.8, so im not going to bend over backwards trying to figure out hacky ways via NMS to help someone, they are on their own, I just let others offer help.
     
    • Agree Agree x 5
    • Like Like x 1
    • Winner Winner x 1
  13. I disagree.
     
    • Optimistic Optimistic x 1
  14. And there's absolutely no way this will happen once people figure out that the 1.15 tag is like crack to people willing to help, and the 1.8 tag makes ghost town threads.

    It's almost as if this wasn't such a great idea to begin with. I'll give it the benefit of the doubt and say that I'm super excited to see where it goes, and I hope that I'm completely wrong about it.

    Keep on taggin', folks!
     
  15. Thanks for the constuctive feedback as always Mr. Ivan, much appreciated.
     
    • Winner Winner x 5
  16. Maybe the situation would improve by changing the tags slightly - Since the bukkit api is forward compatible, maybe the tag should be something like [1.8.8+] ie. the lowest wanted supported version? This would make it seem a bit less like the version is the "supported version" for the question

    This would also keep the answers future proof for newcomers, as the solutions will likely work in the future, but the current tag will not communicate that.
     
    • Optimistic Optimistic x 1