Solved Repair plugin like Griswold

Discussion in 'Spigot Plugin Help' started by Lordcre_, Jun 17, 2016.

Thread Status:
Not open for further replies.
  1. #2 iPyronic, Jun 17, 2016
    Last edited: Jun 17, 2016
  2. I keep getting the same problems... When a user tries to use him.. It just opens a regular villagers GUI. Permissions don't work and you can also push him around...
     
    #3 Lordcre_, Jun 17, 2016
    Last edited: Jun 17, 2016
  3. How about this edit?
    https://mega.nz/#!PpZSkA5A!xciS5yBg3XfW6QaqhLCDVIWlCfCwEItN8PKYgw9hMEI

    If there's still permission problems in this version, could you be a little more specific about what exactly isn't correct with them?
     
  4. Permissions problem fixed. It now works like it should when users click it. But what about the NPC being able to be pushed? Also, is there anyway you could change how you create a blacksmith? It's a bit buggy- making it spawn where you're standing would be perfect..
     
  5. put it in a cage and dont let it out
     
  6. I made it teleport the NPC back to its creation location if it's pushed to a block with a different X,Z coordinate

    And here's a new edit: https://mega.nz/#!7h4wFZAJ!RhcV0Dh7xuz57x4BRRs5w0z3PcHHNxmnT207Dxts4g4
    The creation location is now where you're standing when you use the command
    /griswold is now a valid command, and is the same as /blacksmith and /bsmith
    Made some new command info text for when you just type "/griswold" and nothing after it
    All of the commands have some fancy tab-completion now to help you out while using them
    NPCs start with a 1.9-compatible sound name now when they're created
    Fixed a NPE in the entity target event
    Added some lightning protection to prevent witches
     
    #7 iPyronic, Jun 18, 2016
    Last edited: Jun 18, 2016
    • Useful Useful x 1
  7. You are amazing! Thank you so much!
     
    • Friendly Friendly x 1
  8. Oh hey, one more thing @iPyronic. When creating a blacksmith on ground (minecraft ground unedited)- it works fine. But when trying to create a villager on (for instance) a 2 block high surface, it doesn't seem to spawn the villager. I've even tried creating it on ground and changing the location of the villager to the proper location and reloading but it still doesn't seem to work either.. Is there anything you could do?
     
  9. I tried creating a new one on some glass and it worked as expected. Am I doing something differently than you?

    Edit: I've noticed you can't have two villagers with the same name due to the way it manages them, dunno if that's part of the problem you're having though.
    [​IMG]
     
    • Useful Useful x 1
  10. Perfect! It works! You're the most help I've had in a while- I really appreciate it!
     
    • Friendly Friendly x 1
Thread Status:
Not open for further replies.