Spigot Residence Reloaded 1.8.x 2.6.7.0

Residence, Protection

  1. We need WorldEdit ?
     
  2. Please take a look

    [Residence] Found Vault using permissions plugin:GroupManager
    [10:27:13] [Server thread/ERROR]: null
    java.lang.NullPointerException
    at com.bekvon.bukkit.residence.protection.WorldFlagManager.parsePerms(WorldFlagManager.java:98) [Residence.jar:?]
    at com.bekvon.bukkit.residence.protection.WorldFlagManager.<init>(WorldFlagManager.java:37) [Residence.jar:?]
    at com.bekvon.bukkit.residence.Residence.onEnable(Residence.java:213) [Residence.jar:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) [spigot-1.8.3-R0.1-SNAPSHOT.jar:git-Spigot-870264a-3ded061]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:335) [spigot-1.8.3-R0.1-SNAPSHOT.jar:git-Spigot-870264a-3ded061]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.8.3-R0.1-SNAPSHOT.jar:git-Spigot-870264a-3ded061]
    at org.bukkit.craftbukkit.v1_8_R2.CraftServer.loadPlugin(CraftServer.java:356) [spigot-1.8.3-R0.1-SNAPSHOT.jar:git-Spigot-870264a-3ded061]
    at org.bukkit.craftbukkit.v1_8_R2.CraftServer.enablePlugins(CraftServer.java:316) [spigot-1.8.3-R0.1-SNAPSHOT.jar:git-Spigot-870264a-3ded061]
    at net.minecraft.server.v1_8_R2.MinecraftServer.r(MinecraftServer.java:416) [spigot-1.8.3-R0.1-SNAPSHOT.jar:git-Spigot-870264a-3ded061]
    at net.minecraft.server.v1_8_R2.MinecraftServer.k(MinecraftServer.java:382) [spigot-1.8.3-R0.1-SNAPSHOT.jar:git-Spigot-870264a-3ded061]
    at net.minecraft.server.v1_8_R2.MinecraftServer.a(MinecraftServer.java:337) [spigot-1.8.3-R0.1-SNAPSHOT.jar:git-Spigot-870264a-3ded061]
    at net.minecraft.server.v1_8_R2.DedicatedServer.init(DedicatedServer.java:257) [spigot-1.8.3-R0.1-SNAPSHOT.jar:git-Spigot-870264a-3ded061]
    at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java:522) [spigot-1.8.3-R0.1-SNAPSHOT.jar:git-Spigot-870264a-3ded061]
    at java.lang.Thread.run(Thread.java:745) [?:1.7.0_75]
     
  3. Is there anyway to set a delay for /res tp? I have an issue with players making res sizes that are 0,0,0 and using them as homes.
     
  4. Can i do like the user can create 2 residences and vip 4
     
  5. I have same problem :/ I try update 2.6.6.7 to 2.6.7.0
    What it is???
     
  6. I went through the process of manually updating close to 90k lines of data since the internally converted doesn't work. Now the server hangs on starting at residence for about 10 mins and even after that point the server crashes shortly after because of a severe hit on performance. I cut down on the residence file size to about 26 res plots and it still takes about 2-3mins to startup and still the hit on performance. It really seems this plugin is now dead due to how broken it is and the lack of updates, it is a real shame this plugin was truly great. Does anyone know of any alternatives that have similar features?
     
  7. Yes, I solved this. I waited about 15 minutes and then it go good :)
     
  8. hello! I have been searching around for anyone else having the issue I am having- but can not find a solution.

    using res market - usual /res market rent NAME < etc. it looks like it all works fine in the config and even using resSigns still works from an OP -

    THE ISSUE
    people can successfully rent it out- AND the flags get added/changed BUT they still can not build on the res?

    any ideas? I have tried this with the market commands and with the old resSign plugin

    Help :eek:
     
  9. Hello, I have problem with the plugin, when I link it with Vault (1.5.3) I can't do anything.
    Use the commands of the plugin throws a lot of errors in the console, is impossible to do the primary and secondary selection points, and neither appears the enter/leave messages of a residence.

    So, the problem is the link with vault, so I hope that are going to fix it soon.
     
  10. @DartCZ
    Bug report: with wooden doors you can force acces with SHIFT
     
  11. maybe updates will come?
     
  12. Currently development is on halt as all current dev's don't have spare time for it.
     
  13. Aha ok its ok take a time and for good updates to become in future tnx.
     
  14. Could you tell me how to close the version-check?
    if i open the server, the plugin will print lots of error information when my server can't connect to version-check server
     
  15. Add
    Code (Text):
      VersionCheck: false
    in you config file, don't forget to put 2 spaces in front of it.
     
  16. [​IMG]
    [​IMG]
    it seems that this value doesn't work well
     
  17. Wrong place for it, place at same place as Language: English
    P.S. Soon there will be huge update for residence and you won't gonna need to be worried about stuff like this anymore :)
     
  18. Thanks for the update 2.6.7.0. This is an excellent plugin!
    Found that text message spams the chat after the new version has been installed, hate to disable version-check, but even after adding VersionCheck: false, the message it is still displayed.
    The message says there is a new version 2.7.0.0 but nowhere to be found.
     
    #119 sammi4, Aug 28, 2015
    Last edited: Aug 29, 2015