Resource pack client error

Discussion in 'Server & Community Management' started by Azami7, Jun 12, 2016.

  1. Azami7

    Supporter

    Hi all,

    I am trying to get our server to vend a resource pack and it downloads fine but won't load. I know this topic has come up before but I have read every post on every forum I can find through Google and I am stumped on what the problem is.

    This is for 1.9.4. The error in the client is with the pack.mcmeta. I have looked it over, had 2 friends look it over, and I cannot see a problem with it.

    The error:

    [09:23:28] [Client thread/WARN]: Unable to parse metadata section of resourcepack: 72fba12b641f9b374e6608e41c43bc465abb1f95
    bwg: 'pack.mcmeta' in ResourcePack '*path removed*/minecraft/server-resource-packs/72fba12b641f9b374e6608e41c43bc465abb1f95'
    at bvx.a(SourceFile:40) ~[1.9.4.jar:?]
    at bvr.a(SourceFile:60) ~[1.9.4.jar:?]
    at bwn.a(SourceFile:43) [1.9.4.jar:?]
    at bcd.f(SourceFile:741) [1.9.4.jar:?]
    at bcd$8.run(SourceFile:2535) [1.9.4.jar:?]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_74]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_74]
    at h.a(SourceFile:45) [1.9.4.jar:?]
    at bcd.av(SourceFile:961) [1.9.4.jar:?]
    at bcd.a(SourceFile:399) [1.9.4.jar:?]
    at net.minecraft.client.main.Main.main(SourceFile:124) [1.9.4.jar:?]


    And pack.mcmeta says:

    {
    "pack":{
    "pack_format":2,
    "description":"PotterCraft"
    }
    }


    Please note that "*path removed* was added by me in replacement of my path for security reasons (this being on the internets and all).

    This resource pack works fine when added directly to the /resourcepacks folder in a minecraft client. I have had several people try it. Unzipping the downloaded file in my server_resource_packs folder, 72fba12b641f9b374e6608e41c43bc465abb1f95, works and the contents look exactly like I expect.

    I have tried using the default pack.mcmeta file on http://minecraft.gamepedia.com/Tutorials/Creating_a_resource_pack and it still doesn't work.

    Interesting note, changing "2" to "1" on pack_format makes the error go away but then minecraft just hangs since (assuming because it is expecting the directory structure to match 1.8).
     
  2. Azami7

    Supporter

    And, of course, as soon as I post this, I fixed it. I have no idea why but it seemed to be something with the version of zip on the computer I was using. I tried a different computer and it just worked.