Resourcepack-music ist working - nether-music, not :(

Discussion in 'Spigot Discussion' started by o0Julia0o, May 17, 2018 at 6:02 PM.

  1. hi, i am creating a resourcepack with additonal music and ambient-sounds:
    Code (Text):

    {
      "ambient.cave.cave": {
       "category": "ambient",
       "sounds": [
         "ambient/cave/cave14r"
       ]
      },
      "ambient.weather.thunder": {
       "category": "weather",
       "sounds": [
         "ambient/weather/thunder4r",
         "ambient/weather/thunder5r",
         "ambient/weather/thunder6r"
       ]
      },
     "music.game": {
       "category": "music",
       "sounds": [
         {
           "name": "music/game/aether",
           "stream": true
         }
       ]
      },
       "music.game.nether": {
       "category": "music",
       "sounds": [
         {
           "name": "music/nether/darkening",
           "stream": true
        }
       ]
      }
    }
     
    My folders in the resourcepack are:
    Code (Text):

    asstes\minecraft\sounds\ambient\cave
    asstes\minecraft\sounds\ambient\weather
    asstes\minecraft\sounds\mix
    asstes\minecraft\sounds\music\game
    asstes\minecraft\sounds\music\nether
     
    in which i have placed the respective ogg-files.

    I have 4 questions:
    1. The game-music-files are played. The nether-music-files not(only the vanilla-music is played in the nether). Why?
    I can test it with this command:
    Code (Text):

    execute @a ~ ~ ~ playsound music.nether weather @p ~ ~ ~
     
    or for the normal music:
    Code (Text):

    execute @a ~ ~ ~ playsound music.music weather @p ~ ~ ~
     
    The addet game-music is played. But the addet nether-music not. If i use the nether-ogg-files for game-music they are working, too. So the ogg-files for themselves are woking.

    2. The additional thundersounds aren´t played, too if i do:
    Code (Text):
    /execute @a ~ ~ ~ playsound entity.lightning.thunder weather @p ~ ~ ~
    Only the vanilla-thunder-sounds are played. Why? If i test the new thundersounds as sound like the cave14r-sound in question 3, they are played with the respective command. But not working as ambient.wether.thunder-sound.


    3 .The cave14r.ogg i didn´t hear, too. Only the vanilla-cave-sounds are played. Why? If i use the same ogg-file as sound-file in sound.json:
    Code (Text):

    "cave14r": {
     "category":"cave14r",
     "sounds": [
     {
     "name":"mix/cave14r"
     }
     
    i can play the sound with:
    Code (Text):
     /execute @a ~ ~ ~ playsound cave14r weather @p ~ ~ ~
    So the sound-file itself is working. I test the cave-ambient sounds like this:
    Code (Text):
     /execute @a ~ ~ ~ playsound ambient.cave weather @p ~ ~ ~
    But as said, at no time the cave14r.ogg is played.


    4. Are the sounds i addet as resourcepack additonally to the vanilla-sounds(if the name isn´t the same like the vanilla-sounds)?

    Can you help me with one question? Thank you!
     
    #1 o0Julia0o, May 17, 2018 at 6:02 PM
    Last edited: May 17, 2018 at 6:24 PM
  2. the cave-sounds have to be mono, to be played. But you can maximum have 17 cave-songs. You don´t have to link them in the sound.json like the normal music.

    But even in mono i can´t add thunder-sound. And i can´t replace pic/death.ogg-sound with linking it in the sound.json. The vanilla one is played all the time.
     

Share This Page