1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug /restart doesn't work (right folder)

Discussion in 'Bugs & Feature Requests' started by Meow, Feb 16, 2013.

  1. I set up the right folder in bukkit.yml:
    restart-script-location: /root/minecraft/start.sh

    However, when I type /restart, it just stopped the server. Same as autorestart on crash
    2013-02-17 06:41:31 [INFO] Attempting to restart with /root/minecraft/start.sh
    2013-02-17 06:41:31 [INFO] Stopping server
    2013-02-17 06:41:31 [INFO] [Essentials] Disabling Essentials v2.10.1
    2013-02-17 06:41:31 [INFO] [WorldEdit] Disabling WorldEdit v5.5.1
    2013-02-17 06:41:31 [INFO] Saving players
    2013-02-17 06:41:31 [INFO] Saving worlds
    2013-02-17 06:41:31 [INFO] Saving chunks for level 'world'/Overworld
     
  2. is the script location supposed to be a relative path from the jar or absolute path?
     
  3. LiLChris

    LiLChris Retired Moderator
    Retired

    I also have tried a dozen combinations, gave up on /restart.
     
    • Agree Agree x 1
  4. Same as LilChris, I've tried dozen combinations, never worked for me nor anyone else
     
  5. LiLChris

    LiLChris Retired Moderator
    Retired

    Really could have used a restart today, dam crash. :(
     
  6. you're hosting in root folder? are you hosting with root user? =/
     
  7. This is just a test server of mine, the other public servers run as user :)