Premium [REWORK IN PROGRESS] CombatPets | 1.13 - 1.14 [Paid]

Discussion in 'Resource Discussion' started by NightExpress, Feb 19, 2018.

  1. NightExpress submitted a new resource:

    MMOPets - Pet stats | Shop | Catching | Customizable | Leveling

    Read more about this resource...
     
  2. The plugin looks good,i wanna purchase it,but i have a question.
    Does it support 1.9.4?
     
    #2 alexdemond, Feb 19, 2018
    Last edited: Feb 19, 2018
  3. Пара запросов.
    1. Добавить поддержка SAPI для экипировки мобов. Т.е моб 5 уровня может одеть броню, оружие 5 и ниже уровня. Все как с игроком.

    2. Добавить возможность прокачивать инвентарь.

    3. Добавить дополнительные свойства мобом, которые бы позволяли украшать их:
    - fire - поджигает моба
    - invisible - делает его невидимым

    4. Можно функцию Attack: true/false которая бы запрещала мобу атаковать. Т.е делало бы его чисто ездовым

    5. Возможность ограничивать вещи для определенных петов. Как, например, с классами в SAPI, типо:
    Только для 5 уровня
    Только для Быстрой лошади(это имя пета или ID)

    6. Можно ли добавить настройку equip: true/false которая бы запрещала одевать на моба броню через GUI в игре

    7. Добавить возможность стартовых вещей для моба(с поддержкой черепов), а если будет equip: true/false, то можно создавать неких уникальных петов с опр.броней.

    8. Новый тип прокачки пета: Ride. Питомец прокачивается если на нем катаешься.

    Спасибо :)
     
  4. No it does not.

    1. Ok
    2. I'll try
    3. I'll try
    4. Ok
    5. Ok
    6. Ok
    7. Ok
    8. I'll try
     
    • Like Like x 1
    • Funny Funny x 1
  5. Oh,umm but is it possible to support 1.9.4?i really like it:p
     
  6. Technically yes, but I'm not likely to do it. Update to 1.10 would be easier, I guess. But maybe, maybe.
     
    • Like Like x 1
  7. Before i purchase, do you have any plans on adding divineitems attribute support for pet armor and weapons? such as that if you give your pet zombie a sword with 10-30 dmg it will inflict said dmg on top of its normal dmg?
     
  8. Already done. DivineItems by default supports all the entities that can use weapons and armors. And I have tested it, pets using DI weapons dealing more damage with damage types, criticals etc.
     
    • Like Like x 1
  9. Hello, I wonder if this plugin is 100% translatable
     
  10. Hello, this plugin is 100% translatable. You can see all the plugin messages in configs.
     
  11. Maybe I found a problem, it doesn't hook with Vault (Tested with MMOPets 1.0.1, Vault 1.6.6 Spigot 1.12.2)
    It didn't show the hook message when enabling this plugin, then I can't open the shop GUI in game.
    (I didn't purchase this plugin but my friend Pangxie did, we are running a server together.)
     
  12. Make sure you have enabled Vault hook in the config.
     
  13. Oh...Sorry it's my fault...
     
  14. Hello. After leveling up a pet (reaching level 2) the pet has infinite upgrade skill points. Please fix. Thanks! :)
     
  15. I'll check it
     
    • Like Like x 1
  16. the same problem, please fix, thanks.:)
     
  17. I am waiting for support libsdisguises feature, if you taming a pet that has libsdisguises, then apply that libsdisguises to your pet's outfits.
    For example, if you taming a spider with libsguises as a skin "notch", then you will have a pet type player and skin notch.
    Sorry, my bad english
     
  18. My idea of a fruit tree plugin
    I would like to have the Unbreakable item with the NBT tag when using the skull item and drop the head item