Spigot RPGChat [1.8-1.16.x] 1.7.0-BETA

Chat on your server in the RPG Way!

  1. Hey,
    when does support for 1.17.1 come?
    Thank you in advance!
     
  2. Hey,
    support for 1.17.1 will be added with the next update 1.6.1 which also includes a bug fix for the Chat-Filter :)
     
  3. Hey, thanks for the update :)
    Sadly i have got a bug and the messages won't get removed:

    Code (Text):
    [11:27:51 WARN]: [RPGChat] Task #16132 for RPGChat v1.6.1-BETA generated an exception
    java.lang.NoSuchMethodError: 'void net.minecraft.network.protocol.game.PacketPlayOutEntityDestroy.<init>(int)'
            at de.sirzontax.rpgchat.nms.v1_17_R1.RyeStand.destroyEntity(RyeStand.java:62) ~[RPGChat-BETA.jar:?]
            at de.sirzontax.rpgchat.utils.ChatUtils$3.run(ChatUtils.java:186) ~[RPGChat-BETA.jar:?]
            at org.bukkit.craftbukkit.v1_17_R1.scheduler.CraftTask.run(CraftTask.java:101) ~[patched_1.17.1.jar:git-Paper-196]
            at org.bukkit.craftbukkit.v1_17_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:483) ~[patched_1.17.1.jar:git-Paper-196]
            at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:1490) ~[patched_1.17.1.jar:git-Paper-196]
            at net.minecraft.server.dedicated.DedicatedServer.b(DedicatedServer.java:479) ~[patched_1.17.1.jar:git-Paper-196]
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:1406) ~[patched_1.17.1.jar:git-Paper-196]
            at net.minecraft.server.MinecraftServer.x(MinecraftServer.java:1188) ~[patched_1.17.1.jar:git-Paper-196]
            at net.minecraft.server.MinecraftServer.lambda$spin$0(MinecraftServer.java:316) ~[patched_1.17.1.jar:git-Paper-196]
            at java.lang.Thread.run(Thread.java:831) [?:?]
     
  4. This is a bug because of a difference in packets in 1.17 and 1.17.1, I fixed this issue in update 1.6.2 but I think with the fix 1.17 is no longer supported, only 1.17.1 and above!
     
  5. Hey,
    would it be possible if you could add support for a server wider chat aß a channel? So you can have the normal minecraft chat and the for close range the rpg chat.
    That would be great :)
     
  6. Hey,

    do you mean, you can decide where you write?
     
  7. Yes, so you can use the channel command to switch the channels. For example from the local head chat to the global chat to answer some questions from players which they asked in the global chat.
     
  8. I will consider it for update 1.8.0!
     
  9. Hey, i do not get a error message in console or in game. I use 1.17.1 spigot on my server and the latest version of the rpgchat plugin. Is it depending on another pluign to work?
     
  10. No, it isn't. Did you change to config.yml, so that the chat is enabled?
     
  11. SirZiegenKease updated RPGChat with a new update entry:

    Added new features

    Read the rest of this update entry...
     
  12. Support for 1.17.1? I tried this plugin out and it says that it's an unsupported version.
     
  13. Hey, as stated in the description, support for 1.17 and above will be only in the premium version of this plugin. It'll be released soon with more features, more frequently updates and support for all new versions.