1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug Save-all Bug (Remote Command)

Discussion in 'Bugs & Feature Requests' started by Nosxxx, Sep 29, 2013.

  1. If i shutdown the Server with my webinterface it sends automatically a save-all command. On bukkit it works fine, but on spigot it does not save the world.

    http://pastebin.com/1CZ1je6r
     
  2. Dmck2b

    Services Staff

    What is your startup command? If it doesnt have --nojline, add it.
     
  3. hmm
    nogui is my start command

    java -Xms1024M -Xmx4096M -jar craftbukkit.jar nogui


    how should the command look like ?
     
  4. Dmck2b

    Services Staff

    java -Xms1024M -Xmx4096M --nojline -jar craftbukkit.jar nogui

    Should be it. Otherwise, try remove one of the -'s before nojline. I don't have a linux box offhand to double check which it is.
     
  5. That does not work ;(
    The Server is running on Debian 6
     
  6. Dmck2b

    Services Staff

    Can't do much to help then. Error is to do with jline and that's the only way to disable it. Shouldn't be an issue on linux since it's a visual c++ library. Must be an issue with your interface.
     
  7. Thanks, but if i use bukkit it works, so i dont think there is an issue with the interface.
     
  8. Is there a known issue with jline and RCON?

    And Nosxxx, I assume you are using RCON? or are you using a separate plugin?