Spigot ScytheEssentials 1.0 2017-06-03

The plugin you need!

  1. Linkups submitted a new resource:

    ScytheEssentials 1.0 - The plugin you need!

    Read more about this resource...
     
  2. I hope you realize that this itself is a replica of essentials, so actually you have no right to take down others videos or plugins.
     
  3. Actually, tecnically its a custom made