1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Solved Server Crash, Only on midnight restart ~Not a bug XD Sorry

Discussion in 'Bugs & Feature Requests' started by daboross, Jan 24, 2013.

  1. I just had a crash, when my server was starting up with my midnight restart script. I just started it up about 20 minutes later, and it worked. Here is the LOG: http://pastebin.com/PqTRdgiB
    Please tell me if I need more INFO, or if there is a fix.
     
  2. md_5

    Administrator Developer

    This is a Bukkit bug involving plugins using threads (from what I can see anyway), its pretty rare, but we have a test fix in the very latest builds.
     
  3. Ok, I will update to the latest dev build. I think the only plugin that I have that is using threads is core protect, and I am only sure that it does because of a few times it has "saved" my server from crashing, which I am pretty sure it can only do from a different thread.
    Code (Text):
    2013-01-09 18:38:32 [INFO] ------------------------------
    2013-01-09 18:38:33 [INFO] [CoreProtect] Server appears to be hanging!
    2013-01-09 18:38:33 [INFO] [CoreProtect] Command used by Overkill_Dude: //stack 10
    2013-01-09 18:38:33 [INFO] [CoreProtect] Gracefully aborting command.
    2013-01-09 18:38:33 [INFO] ------------------------------
    That is what core protect does when someone uses a command that would crash the server.
    Also, I think that mcMMO might be using threads because people can talk in it's admin/group chat even when the server isn't responding.
    I believe the crash that I am happening only happens at midnight though, for some reason.
     
  4. Ok, I think this became a bit more critical with the latest build. I think this might be caused by a plugin, but I am getting a similar error every time I try to start the server. Here is the log: http://pastebin.com/s0LyJLLA
    This is happening with build #452
    EDIT:
    I just tried it with craftbukkit and still happening, so I guess it isn't Spigot. :p.

    EDIT:
    It seems that the plugin "PlayerData" is causing this error. I have no idea what in the code is doing this though. I develop this plugin for my server, and I am not sure what is causing it in my code.
     
    #4 daboross, Jan 25, 2013
    Last edited: Jan 25, 2013
  5. CommandHelper (com.laytonsmith.abstraction) is your issue. Get rid of it.
     
  6. Ok. I did go to the CommandHelper IRC, and they did say that CommandHelper was in the other thread, and wasn't causing it. I thought it was PlayerData because of this:
    https://gist.github.com/4638985
    that is part of this error:
    https://gist.github.com/raw/4638967/d99150b2aac7b2fbf258527f15c277d55f99d84e/gistfile1.txt

    This is what CommandHelper was saying:
    I am not sure if I can run my server without commandhelper because I kind of rely on some of its features.
     
  7. md_5

    Administrator Developer

    Does it happen every time?
     
  8. I am not sure, I did get the server to start normally after putting in the CraftBukkit beta build, and removing PlayerData.
    Then loading PlayerData back in after the server was loaded. There are quite a few people on my server right now, so I can't check, but that last error only happened twice this morning. once with Spigot and once with Bukkit.

    EDIT:
    Ok. This is happening every time I start up when I have PlayerData in my plugin folder. I have no idea why PlayerData is causing this, I can show you the source code if you want.

    I am going to go to the plugin dev section in bukkit to see if I can figure this out. It is probably an error in my code, though I have no reason why it causes a stack overflow.
    Code (Text):

    2013-01-26 09:58:03 [INFO] [PlayerData] Enabling PlayerData v1.3
    2013-01-26 09:58:06 [INFO] [PlayerData] Loaded 1,092 Player Data Files
    2013-01-26 09:58:06 [INFO] [PlayerData] Loaded 274 Alive Player Data Files
    2013-01-26 09:58:06 [INFO] [PlayerData] Loaded 818 Dead Player Data Files
    2013-01-26 09:58:06 [INFO] [PlayerData] PlayerData Enabled
    2013-01-26 09:58:06 [SEVERE] null loading PlayerData v1.3 (Is it up to date?)
    java.lang.StackOverflowError
        at java.lang.String.toLowerCase(Unknown Source)
        at org.bukkit.plugin.SimplePluginManager.subscribeToPermission(SimplePluginManager.java:620)
        at org.bukkit.permissions.PermissibleBase.calculateChildPermissions(PermissibleBase.java:187)
        at org.bukkit.permissions.PermissibleBase.calculateChildPermissions(PermissibleBase.java:190)
        at org.bukkit.permissions.PermissibleBase.calculateChildPermissions(PermissibleBase.java:187)
        at org.bukkit.permissions.PermissibleBase.calculateChildPermissions(PermissibleBase.java:187)
        at org.bukkit.permissions.PermissibleBase.calculateChildPermissions(PermissibleBase.java:187)
    ...
    I just realized what I did wrong XD. This was REALLLLLLLY Silly of me!
    Code (Text):

      playerdata.help:
        description: Allows you to use /pd ?
        default: true
        children:
          playerdata.help: true
     
    That is just...
     
    #8 daboross, Jan 26, 2013
    Last edited: Jan 27, 2013