Server crashes from new unloaded chunks

Discussion in 'Spigot Help' started by jojo1107MC, Apr 2, 2020.

  1. Hi,
    I have a skyblock server with a flat world.
    I don't remember why, but I decided to fly in speed 10 to explore the flat world (there were only villages lol)
    For some reason, the chunks stopped loading and the server crashed. After that, I couldn't rejoin without the server crashing.

    I tried Queued Commands and SpawnTP, but I quickly realized that the server shuts down before commands could execute.

    Is there any way I could fix this?

    - Jojo1107
     
  2. Do you have a backup?

    Your 'skyblock' plugin, or, just the server load probably corrupted some chunks?

    Your info is not enough for anyone to provide anywhere near definative solution.

    Some server logs may help?
     
  3. wdym?
     
    1. Stop the server.
    2. Delete your userdata from the world's folder, and it will reset your position to the spawnpoint.
    3. Start the server.
    Hope this helps.
     
  4. Thanks.
    I tried this and I didn't go back to my spawn point.
    The world name was AP (which stands for Amusement Park), and I deleted ALL playerdata files and I still can't log on.
    Did I do something wrong?
    Thanks for trying to help though
     
  5. Hmm...
    Do you have any login plugin or a plugin which teleports you on login?
     
  6. Yes. I tried SpawnTP but that doesn't work. I still get stuck in the chunks
     
  7. One of your plugins (probably the authentication one) teleports you somewhere in your world, where chunks weren't laoded before.
    Try disabling your auth plugin, and see if the problem is solved. If it is, then remove yourself from the plugin's userdata, and that should do it.
     
  8. I'm sorry for the late reply,
    is the plugin: " DiscordSRV" the auth plugin?
    If not,
    what other auth plugins are there that I might have?