1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Solved Server Crashes right after midnight restart

Discussion in 'Bugs & Feature Requests' started by daboross, Jan 15, 2013.

  1. This seems to be 2 glitches. Every time recently that my midnight auto-restart script has run, the server crashes directly after it starts up. This happened in build 389 and in build 371.
    Here is the server log from when it crashed to when I started it back up again:
    http://pastebin.com/Zzqbgh5g
    Another error I seem to be having is that after this crash, Spigot tries to restart using the script that I have, start.sh. start.sh is placed in my server folder, and I use it to start the server every time, but for some reason spigot thinks it "does not exist."
    Also, I noticed this line:
    [SEVERE] [Fatal Error] :77:37: An invalid XML character (Unicode: 0x1b) was found in the element content of the document.
    And I am not sure which document that is.
    I could not find a server crash file associated with this. And for some reason this error only happens when the auto-restart script is restarting it, but not when I do manually.
    If you want to see the auto-restart script, here it is: http://pastebin.com/x53CNf1L
    This is the CronTab job that runs it:
    54 23 * * * /home/newlanders/bin/wkr.sh
    Hope you can find what I have done wrong, or fix this error if it is an error!

    This has fixed with the new build, Thank You!
     
    #1 daboross, Jan 15, 2013
    Last edited: Jan 20, 2013
    • Useful Useful x 1
  2. Your restart script is insane! too complicated that I cannot understand it in any ways.

    But talking about spigot restart script I guess you have to type the full patch in spigot.yml.

    startup-script: /home/username/minecraft/./start.sh