Solved Server crashes when world loads

Discussion in 'Spigot Help' started by SirHawkEye, May 15, 2016.

  1. Hey there,

    I'm trying to have multiple worlds on my server, three of the normal dimensions, and one that is empty with a single building in it. No matter what world I use, be it pre-built or fresh generated, as soon as more than the initial chunks generate (I move a few chunks), the server crashes.

    There are no plugin errors, it just stops responding.

    Error log: http://pastebin.com/hFWggQgx
    Plugins: http://prntscr.com/b4e9hh
    Version: http://pastebin.com/UdKQS8LY (I'm running 1.9.2 because 1.9.4 broke my world generator)

    Is there anything I can do? I need to have this other world. Thanks for any help!
     
    #1 SirHawkEye, May 15, 2016
    Last edited: May 15, 2016
  2. Sorry for bumping, but this is a really big issue!
     
  3. As in internet speed? I'm using a shared host, not a dedicated box. What (if anything) can I do on the server side?
     
  4. This is clearly not a network problem. Network issues cannot crash a server under any conditions.

    Please do not try to answer questions is you have no idea what the problem is, guesses waste time.

    com.pl.MYCRAFTisbest.RWtorchLight.RWtorchLight.onPlayerMove is causing an infinite loop which freezes the server.

    Solution: remove shitty plugin.
     
    • Agree Agree x 1
  5. Create badly packed? What does that even mean?
    A bad packet? A server cant send packets to itself, and there is no such thing as a bad packet that can crash a server. Servers have to be able to handle any possible packets, otherwise it would be extremely easy for glitches or griefers to shut the server down instantly.

    You can tell from the error log that the crash is due to the server freezing, which means an infinite or near-infinite loop.
     
    • Agree Agree x 1
  6. I removed the plugin and all works now, thanks!
     
  7. Good. In future, you can always just look at the error log. It usually shows the plugin that is responsible in the Stacktrace (list of things the server was doing when it crashed) and just try disabling the plugin(s) you see there.