server error when joining

Discussion in 'Spigot Help' started by Eric_Minecraft, Aug 15, 2018.

  1. Hello, I run a two small servers for me and my friends, the 1.13 server randomly started acting strange.
    when I connect using localhost it works fine but when my friends join they get the error
    Code (Java):
    bad packet id 27

    and this error appears in console
    Code (Java):
    [16:16:37] [Server thread/WARN]: Failed to handle packet for /ip.ip.ip.ip:55877
    java.lang.IllegalStateException: Not a JSON Object: null
        at com.google.gson.JsonElement.getAsJsonObject(JsonElement.java:90) ~[server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.ServerStatisticManager.a(ServerStatisticManager.java:90) ~[server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.ServerStatisticManager.<init>(ServerStatisticManager.java:49) ~[server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.PlayerList.getStatisticManager(PlayerList.java:1337) ~[server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.EntityPlayer.<init>(EntityPlayer.java:95) ~[server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.PlayerList.attemptLogin(PlayerList.java:497) ~[server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.LoginListener.b(LoginListener.java:130) ~[server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.LoginListener.Y_(LoginListener.java:54) ~[server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.NetworkManager.a(NetworkManager.java:231) ~[server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.ServerConnection.c(ServerConnection.java:120) [server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.MinecraftServer.w(MinecraftServer.java:984) [server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.DedicatedServer.w(DedicatedServer.java:411) [server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.MinecraftServer.v(MinecraftServer.java:819) [server.jar:git-Spigot-2b0e71c-4a24108]
        at net.minecraft.server.v1_13_R1.MinecraftServer.run(MinecraftServer.java:717) [server.jar:git-Spigot-2b0e71c-4a24108]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_181]
    [16:16:37] [Server thread/INFO]: com.mojang.authlib.GameProfile@4849b4b6[id=cd0e788d-405b-45b3-bfa3-dc46b4f0cf1e,name=js5769,properties={textures=[com.mojang.authlib.properties.Property@5bbe902b]},legacy=false] (/ip.ip.ip.ip:55877) lost connection: Internal server error

    also I have found that putting the server in offline mode fixes it.
    it was working before yesterday, I have tried multiple versions of spigot and paperspigot
     
  2. Are you building your own build of spigot or are you downloading spigot from another website?
     
  3. Im building my own spigot from latest build-tools. when I used paper I downloaded it from the official paper-spigot site.
     
  4. im going to guess that either its a client side problem (probably not) or its a plugin problem. I have never seen an issue like that. Trying removing plugins and see if the problem persists.
     
  5. It happens to everyone except me.

    I tried removing all plugins, still happens.
     
  6. So you have a fresh new build of spigot, and you have no plugins.
    Im going to guess its something wrong with the machine you are running on, or ports aren't properly forwarded.
     
  7. I have 2 servers running on this machine, the 1.12.2 (port 25565) server works fine, i tried running the 1.13 server on 25565 but it still had the same issue.
     
  8. I would consider talking to the system admin then.... I really don't think thats an issue on spigots side.
     
  9. It is a server for just me and my friends, I am homehosting.
     
  10. OH, then that might be an issue with your firewall.
     
  11. I have never had an issue with my firewall in the two years that I've been homehosting but ill look at it
     
  12. Hm... not sure what to tell you then. If 1.12 works and 1.13 doesn't, then I really have no clue. I have never heard of anyone having an issue like this.