server EULA problem

Discussion in 'Spigot Help' started by Daniel48541, Jan 24, 2020.

  1. hello, I have a problem that when I start the server, so I write let the EULA allow the server to go, but I did not create the EULA folder, do you know what to do?

    You need to agree to the EULA in order to run the server. Go to eula.txt for more info.
  2. There is no folder. Edit the Eula.txt and replace false with true.
  3. but the EULA wasn't created in my server folder at all.
  4. Whats in your start script?
  5. java -Xmx4096M -Xms4096M -jar server.jar nogui
  6. The EULA was created. The only way I can see it -not- being created is if the program doesn't have write permissions in the folder it's operating in, if that's the case, get that fixed and run it again.
    • Agree Agree x 1
  7. I don't understand the answer very much, my English is not the best. So what do we do then?
  8. Run it through a translator? I'm not sure how to help you out here, I'll attempt to rephrase the answer:

    Your spigot program can not write to the directory it is inside of. You need to fix your write permissions, this is an operating system issue, not a spigot/java one.
  9. Well, thank you for the quick answer.
  10. Yeah, might be Windows Controlled Folder Access / Ransomware Protection (If he is on Windows). I've had the same issue before
  11. Hi,
    If I understood your problem correctly (sorry if it isn't), the best choice is to create a .txt file called "eula.txt" and to put it just like on this capture

  12. unfortunately this option doesn't work :(
  13. What host are you using? Can you try creating a new file called eula.txt?
  14. You could add
    Code (Text):
    to the startup parameters:
    Code (Text):
    java -Xmx4096M -Xms4096M -Dcom.mojang.eula.agree=true -jar server.jar nogui
    But if the file isn't created, something else must be (terribly) wrong and could cause other problems as well.